[IAEP] 'apt-get install sugar-platform' available for Ubuntu9.10.

Grant Bowman grantbow at gmail.com
Sat Oct 31 21:34:51 GMT 2009


You may have some other sources in your /etc/apt/source.list file that
are conflicting.  I've got David's packages installed and running
without those errors.  I saw errors like that were from the older
packages.

I don't think David's packages uninstall or conflict with the older
packages yet to make the upgrade as seamless as it soon will be.  You
can try remove all the older sugar packages.  To find the older
packages try `dpkg -l | egrep sugar` and then apt-get remove the old
ones before installing the new ones.

Grant Bowman
https://wiki.ubuntu.com/CaliforniaTeam


On Fri, Oct 30, 2009 at 3:00 PM, Edward Cherlin <echerlin at gmail.com> wrote:
> There seems to be something missing in the repository, or perhaps
> something else is wrong.
>
> python-sugar-toolkit-0.86:
>  Depends: python-sugar-0.86  but it is not installable
>  Recommends: sugar-0.86  but it is not installable
>  Recommends: python-carquinyol-0.86  but it is not installable
>  Recommends: sugar-presence-service-0.86  but it is not installable
>  Recommends: python-jarabe-0.86  but it is not installable
>
> This is named -0.86, but the version listed is 0.85.
>
> Leaving that out, and installing the rest,
>
> Errors were encountered while processing:
>  sugar-platform
>
> E: /var/cache/apt/archives/olpcsound_1%3a5.10.90-1~ppa2_amd64.deb:
> trying to overwrite '/usr/lib/libcsnd.so.5.2', which is also in
> package libcsnd5.2 1
>
> This is a broken dependency sugar-platform-->olpcsound-->libcsnd5.2
>
> Then when I try sugar-emulator, Xephyr starts, but not Sugar.
>
> sugar-emulator
> [dix] Could not init font path element /usr/share/fonts/X11/cyrillic,
> removing from list!
> [config/dbus] couldn't take over org.x.config:
> org.freedesktop.DBus.Error.AccessDenied (Connection ":1.79" is not
> allowed to own the service "org.x.config.display101" due to security
> policies in the configuration file)
> unrecognised device identifier!
> (EE) config/hal: NewInputDeviceRequest failed (2)
> unrecognised device identifier!
> (EE) config/hal: NewInputDeviceRequest failed (2)
> unrecognised device identifier!
> (EE) config/hal: NewInputDeviceRequest failed (2)
> unrecognised device identifier!
> (EE) config/hal: NewInputDeviceRequest failed (2)
> unrecognised device identifier!
> (EE) config/hal: NewInputDeviceRequest failed (2)
> unrecognised device identifier!
> (EE) config/hal: NewInputDeviceRequest failed (2)
> unrecognised device identifier!
> (EE) config/hal: NewInputDeviceRequest failed (2)
> unrecognised device identifier!
> (EE) config/hal: NewInputDeviceRequest failed (2)
> [dix] Could not init font path element /usr/share/fonts/X11/cyrillic,
> removing from list!
> (EE) XKB: No components provided for device Virtual core keyboard
> [config/dbus] couldn't take over org.x.config:
> org.freedesktop.DBus.Error.AccessDenied (Connection ":1.79" is not
> allowed to own the service "org.x.config.display101" due to security
> policies in the configuration file)
> unrecognised device identifier!
> (EE) config/hal: NewInputDeviceRequest failed (2)
> unrecognised device identifier!
> (EE) config/hal: NewInputDeviceRequest failed (2)
> unrecognised device identifier!
> (EE) config/hal: NewInputDeviceRequest failed (2)
> unrecognised device identifier!
> (EE) config/hal: NewInputDeviceRequest failed (2)
> unrecognised device identifier!
> (EE) config/hal: NewInputDeviceRequest failed (2)
> unrecognised device identifier!
> (EE) config/hal: NewInputDeviceRequest failed (2)
> unrecognised device identifier!
> (EE) config/hal: NewInputDeviceRequest failed (2)
> unrecognised device identifier!
> (EE) config/hal: NewInputDeviceRequest failed (2)
> Warning: unknown distro version, automatic fallback to unstable.
> ERROR: Dependencies information is missing (unknown distribution/version).
>
> So, is this actually a security issue?
>
> On Sun, Oct 25, 2009 at 18:02, David Farning <dfarning at sugarlabs.org> wrote:
>> After a couple of weeks of reading tutorials, help from Aleksey, and
>> some Ubuntu developers there are Sugar packages available for Ubuntu
>> 9.10.
>>
>> For now, these packages are available on the Ubuntu-Sugarteam PPA
>> (personal package archive) at
>> https://launchpad.net/~sugarteam/+archive/0.86 .
>>
>> To use these packages, just add
>> 'http://ppa.launchpad.net/sugarteam/0.86/ubuntu karmic main' to the
>
> 'deb http://ppa.launchpad.net/sugarteam/0.86/ubuntu karmic main'
>
>> end of /etc/apt/sources.list
>>
>> Ubuntu-Sugarteam
>> _______________________________________________
>> IAEP -- It's An Education Project (not a laptop project!)
>> IAEP at lists.sugarlabs.org
>> http://lists.sugarlabs.org/listinfo/iaep
>>
>
>
>
> --
> Edward Mokurai (默雷/धर्ममेघशब्दगर्ज/دھرممیگھشبدگر ج) Cherlin
> Silent Thunder is my name, and Children are my nation.
> The Cosmos is my dwelling place, the Truth my destination.
> http://www.earthtreasury.org/
>
> --
> Ubuntu-sugarteam mailing list
> Ubuntu-sugarteam at lists.ubuntu.com
> Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-sugarteam
>



More information about the Ubuntu-sugarteam mailing list