[Bug 390475] Re: python-hulahop package doesn't include modules for python 2.6

lkcl lkcl at lkcl.net
Tue Aug 25 20:52:33 BST 2009

ok also confirmed: autoreconf is all that's required.  that's enough to trigger the change to pick up the use of /usr/lib/python2.N/dist-packages NOTE THAT IS NOT REPEAT NOT site-packages, see this:

builds python 2.5 and python 2.6 both successful - and, importantly -

python-hulahop package doesn't include modules for python 2.6
You received this bug notification because you are a member of Sugar
Team, which is subscribed to sugar-hulahop in ubuntu.

Status in “sugar-hulahop” package in Ubuntu: New

Bug description:
Binary package hint: python-hulahop

The current binary package for python-hulahop in Jaunty (amd64) does not include bindings for Python 2.6;  only Python 2.4 and Python 2.5 bindings are present.

The package version is python-hulahop_0.4.8~dfsg-3ubuntu4_amd64.

Building from the source package ('apt-get source python-hulahop' followed by 'debuild') produces a working module for 2.6, but this gets installed to the wrong directory (/usr/lib/python2.6/site-packages instead of /usr/lib/python2.6/dist-packages).  Rebuilding the configure script (using 'autoreconf') prior to running debuild produces a package that installs to the correct location.  (This is because the pre-generated configure script in the source tarball was built before LP #377584 was resolved, and so the AM_PATH_PYTHON macro was incorrectly returning the site-packages directory instead of dist-packages.)

More information about the Ubuntu-sugarteam mailing list