[ubuntu-studio-users] ubuntu-studio-users Digest, Vol 143, Issue 7

Janne Jokitalo astraljava at kapsi.fi
Mon Mar 18 07:15:31 UTC 2019


On Sat, Mar 16, 2019 at 11:03:52AM -0400, Jerry Reed wrote:
> Solved: had to remove an old version of Gmic with synaptic first.  I was
> getting a message that I needed to run all upgrades first even though
> everything appeared updated. Once I removed gmic, upgrade was allowed to
> take place. In progress now.

Hi Jerry,

a small info tidbit on command-line package management, if you're not familiar
with it. While 'apt upgrade' does indeed upgrade packages to newer versions,
there may be circumstances where it fails to do so. Here's why:

sudo apt-get upgrade upgrades your packages but doesn't remove or install any
other packages.

sudo apt-get dist-upgrade upgrades your packages and installs or removes other
packages to resolve dependencies so all packages are up-to-date.

sudo apt full-upgrade does the same thing as sudo apt-get dist-upgrade

Credits to [0].

So in the future, if you get stuck with some packages refusing to upgrade, you
can try the 'full-upgrade' mode.


Best regards,

Jaska

[0]:
https://askubuntu.com/questions/605719/the-difference-between-the-different-apt-upgrade-commands/605721

-- 
Janne (astraljava) Jokitalo
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 181 bytes
Desc: Digital signature
URL: <https://lists.ubuntu.com/archives/ubuntu-studio-users/attachments/20190318/cf95158e/attachment.sig>


More information about the ubuntu-studio-users mailing list