[ubuntu-studio-users] 18.04 backport, Ubuntustudio controls and ffado

Mac macdroid53 at gmail.com
Thu Apr 25 15:05:05 UTC 2019


Yeah, I thought about looking at the code...but, haven't got around to
finding it yet. (No matter how many things I check off my todo list it
never gets shorter...)

As for the on board hardware...I kinda guessed since it worked with alsa
and alsa was being directed to a pulse sink/source it was going to act the
same...silly me. :)
(Every time I go off trying to really understand how it all fits together,
digging into alsa config files and such, I get to a high level grok and run
away. ;)  )



On Thu, Apr 25, 2019 at 10:19 AM Ross Gammon <rosco at ubuntustudio.org> wrote:

> Hi Mac (and others),
>
> Yesterday, I tried this for myself and can confirm that the Alsa Jack
> bridge is always enabled after a reboot even if you turn it off before
> shutting down.
>
> I had a quick look at the code to see which configuration files are
> written, but ran out of time before I worked it out.
>
> Hopefully Len who wrote the code will have the time soon to take a look
> at it. In the mean time I will try and take another look and see if I
> can find a workaround.
>
> I submitted a bug to track it:
> https://bugs.launchpad.net/ubuntustudio-controls/+bug/1826413
>
> Regards,
>
> Ross
>
> On 4/25/19 2:48 PM, Mac wrote:
> > After much messing around, on two different installs of 18.04 with the
> > UBS back port with UBS Controls...
> >
> > I can find no way to get the settings I select in Ubuntu Studio Controls
> > to be retained.
> >
> > In the case of the laptop I tested the onboard audio works, but, there
> > is no way to activate the headphone outputs. And, since JACK is started
> > from UBS Controls, I can'[t even get back to the no JACK setup, which
> > did work when the headphones were plugged in.
> >
> > On both PC's the onboard mic input does not seem to sow up on the
> > capture ports, even though 2 are shown. If I have another, capture, for
> > instance, from a USB or firewire mixer, the mic capture works.
> >
> > As a side note. On the desktop, the mobo has 8 outputs, but when these
> > show up in, say Carla, via JACK, only the first two output sound.
> >
> > Since UBS Controls won't allow me to switch back and forth from
> > JACK/ALSA it makes it difficult to really test things.
> >
> > Are there config files that I can edit by hand to force UBS Controls to
> > behave? All the files I've found have not helped.
> >
>
>
> --
> ubuntu-studio-users mailing list
> ubuntu-studio-users at lists.ubuntu.com
> Modify settings or unsubscribe at:
> https://lists.ubuntu.com/mailman/listinfo/ubuntu-studio-users
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.ubuntu.com/archives/ubuntu-studio-users/attachments/20190425/58b70b92/attachment.html>


More information about the ubuntu-studio-users mailing list