[ubuntu-studio-users] [solved] Ubuntu Studio 16.04 XFCE all icons missing

David King linuxman at avoura.com
Wed Sep 20 15:24:33 UTC 2017



On 20/09/17 15:51, David King wrote:
> 
> 
> On 20/09/17 13:36, David King wrote:
>> I have a problem with my Ubuntu Studio 16.04 installation today. It was
>> working okay before, but today, when I logged in, most of the icons were
>> missing, including inside things like Thunderbird.
>>
>> I rebooted and then even the icons on the login screen were all gone,
>> and when I log in, all icons are missing along with the wallpaper.
>>
>> I can boot into a different Linux on the same PC and it is all okay with
>> that.
>>
>> I have tried restoring some files (cache files, session files) from a
>> known good backup, but it makes no difference. I also tried booting with
>> a different kernel and it made no difference.
>>
>> I wonder if it is a problem with the OS there are even no icons at the
>> login screen.
>>
>> I did not do any major updates lately, although there were quite a lot
>> of updates pending, which I was going to install today, but have not
>> done so because of this problem.
>>
>> I have tried searching on Google and could not find any solution.
>>
>> Does anyone else have this problem? Or know what needs to be fixed? It
>> seems like programs can run okay, but without the icons, nothing is
>> really much usable.
>>
>>
>> David King
>>
>>
>>
>>
> 
> 
> I looked around at various files, and found a log file at 
> /var/log/lightdm/seat0-greeter.log
> 
> This shows some errors in loading icons and wallpaper, re not 
> recognising image file formats, which is unusual:
> 
> 
> ** Message: Starting lightdm-gtk-greeter 2.0.1 (Apr 11 2016, 06:05:31)
> ** Message: [Configuration] Reading file: 
> /usr/share/lightdm/lightdm-gtk-greeter.conf.d/01_ubuntu.conf
> ** Message: [Configuration] Reading file: 
> /usr/share/lightdm/lightdm-gtk-greeter.conf.d/30_ubuntustudio.conf
> ** Message: [Configuration] Reading file: 
> /etc/lightdm/lightdm-gtk-greeter.conf
> 
> ** (process:7751): WARNING **: Failed to register client: 
> GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name 
> org.gnome.SessionManager was not provided by any .service files
> Activating service name='org.a11y.atspi.Registry'
> Successfully activated service 'org.a11y.atspi.Registry'
> 
> (lightdm-gtk-greeter:7749): GdkPixbuf-WARNING **: Cannot open pixbuf 
> loader module file 
> '/usr/lib/x86_64-linux-gnu/gdk-pixbuf-2.0/2.10.0/loaders.cache': No such 
> file or directory
> 
> This likely means that your installation is broken.
> Try running the command
>    gdk-pixbuf-query-loaders > 
> /usr/lib/x86_64-linux-gnu/gdk-pixbuf-2.0/2.10.0/loaders.cache
> to make things work again for the time being.
> 




I noticed the above lines, and decided to restore a loaders.cache file 
from a backup, and it worked. Now I can boot into Ubuntu Studio with all 
icons and wallpaper restored.

But I still have no idea why that loaders.cache file disappeared.

David






More information about the ubuntu-studio-users mailing list