[ubuntu-studio-users] Questions about production

Ralf Mardorf ralf.mardorf at alice-dsl.net
Sun Jul 27 11:17:55 UTC 2014


On Sun, 2014-07-27 at 16:23 +0530, Shubham Mishra wrote:
> $ /etc/init.d/rtirq status output 
> 
> PID CLS RTPRIO  NI PRI %CPU STAT COMMAND 
>    80 FF      90   - 130  0.0 S    irq/8-rtc0 
>    75 FF      80   - 120  0.0 S    irq/16-ehci_hcd 
>    77 FF      79   - 119  0.0 S    irq/23-ehci_hcd 
>    79 FF      75   - 115  0.0 S    irq/1-i8042 
>    78 FF      74   - 114  0.0 S    irq/12-i8042 
>    47 FF      50   -  90  0.0 S    irq/9-acpi 
>   152 FF      50   -  90  0.0 S    irq/40-ahci 
>   372 FF      50   -  90  0.0 S    irq/18-ips 
>   439 FF      50   -  90  0.1 S    irq/17-wlan%d 
>  3497 FF      50   -  90  0.0 S    irq/42-mei_me 
>  3498 FF      50   -  90  0.0 S    irq/43-snd_hda_

Please post the output of

$ grep RTIRQ_NAME_LIST /etc/default/rtirq

Your sound device doesn't share it's IRQ, but it has got a bad priority.
The rtirq default is to care about snd drivers, but Ubuntu Studio has
got the tendency to use current lowlatency kernels, but stay with
outdated rtirq scripts, that don't fit to the kernel.

Please also post the output of

$ sudo apt-cache policy rtirq-init
$ uname -rm

On Sun, 2014-07-27 at 16:24 +0530, Shubham Mishra wrote:
> So I should get an external audio interface which has a mic preamp and
> midi in and not use onboard card at all?

Not necessarily! But one step after the other, first we need to find out
why you experience xruns. You set up the CPU frequency scaling to
performance?




More information about the ubuntu-studio-users mailing list