[ubuntu-studio-users] tuxguitar broken?

bart deruyter bart.deruyter at gmail.com
Tue Nov 26 08:01:00 UTC 2013


For any other interested people:

Seems like the issue is not caused by any ppa, nor using any version of
java, but by oxygen-gtk as gtk setting in look of KDE. Changing it to
something else, seems to solve the issue, at least here it does:

http://ubuntuforums.org/showthread.php?t=2186523

By the way, I understand that limiting support to ubuntu-studio packages is
limiting scope, but at the same time suggesting to use third-party ppa's as
a solution.. well... it is a contradiction, isn't it?

If support for ubuntu-studio is strictly limited to the softwarepackages of
ubuntu-studio itself, then don't suggest third-party packages as a
solution.
It would mean the person in question would not be able to get any help in a
later issue, because of actions suggested by the provider of the support.

Grtz,

Bart

http://www.bartart3d.be/
On facebook <https://www.facebook.com/pages/BartArt3D/169488999795102>
On Twitter <https://twitter.com/#%21/Bart_Issimo>
On Identi.ca <http://identi.ca/bartart3d>
On Google+ <https://plus.google.com/u/0/b/116379400376517483499/>


2013/11/14 Mike Holstein <mikeh789 at gmail.com>

>
>
>
> On Thu, Nov 14, 2013 at 1:42 PM, bart deruyter <bart.deruyter at gmail.com>wrote:
>
>> Mike,
>> - I just sent the error message when starting in terminal in my previous
>> email.
>> - Installing the ppa, and using this version of Java is what I already
>> tried too. First attempt was with default Java in Ubuntu, which is 7 . This
>> Ubuntustudio 13.10 is installed this weekend KDE is added and KX-studio
>> repo's,
>> - Just tried openjdk-6 : no fix
>>
>> Time for a bug-report?
>>
>
> no.. no need for a bug report here, since you are not using ubuntustudio.
> you will troubleshoot this with kxstudio support. sorry, i had intended
> before to ask you to use the suggestion from the error message and run the
> command from the terminal with the  "ulimit -c unlimited"  option.. you can
> try the unsupported ppa i mentioned which will offer java 8 AFAIK.. you can
> try with stock ubuntustudio from a live CD.. good luck!
>
>
>>
>> grtz,
>>
>> Bart
>>
>> http://www.bartart3d.be/
>> On facebook <https://www.facebook.com/pages/BartArt3D/169488999795102>
>> On Twitter <https://twitter.com/#%21/Bart_Issimo>
>> On Identi.ca <http://identi.ca/bartart3d>
>> On Google+ <https://plus.google.com/u/0/b/116379400376517483499/>
>>
>>
>> 2013/11/14 Mike Holstein <mikeh789 at gmail.com>
>>
>>>
>>>
>>>
>>> On Thu, Nov 14, 2013 at 1:12 PM, bart deruyter <bart.deruyter at gmail.com>wrote:
>>>
>>>> Done some more attempts, crash happens even when pressing cancel or
>>>> 'escape' when in the setup options.
>>>>
>>>> I can't even get the option to change audio system to pulse or jack, it
>>>> crashes before I enter the audio settings menu.
>>>>
>>>> starting from terminal, it seems like java is crashing, but I don't
>>>> know much about Java in general, so... :
>>>>
>>>> #
>>>> # A fatal error has been detected by the Java Runtime Environment:
>>>> #
>>>> #  SIGSEGV (0xb) at pc=0x00007f26a535010c, pid=9776, tid=139804568499968
>>>> #
>>>> # JRE version: Java(TM) SE Runtime Environment (7.0_45-b18) (build
>>>> 1.7.0_45-b18)
>>>> # Java VM: Java HotSpot(TM) 64-Bit Server VM (24.45-b08 mixed mode
>>>> linux-amd64 compressed oops)
>>>> # Problematic frame:
>>>> # C  [libgobject-2.0.so.0+0x3210c]  g_type_check_instance_cast+0x1c
>>>> #
>>>> # Failed to write core dump. Core dumps have been disabled. To enable
>>>> core dumping, try "ulimit -c unlimited" before starting Java again
>>>> #
>>>> # An error report file with more information is saved as:
>>>> # /home/bart/hs_err_pid9776.log
>>>> #
>>>> # If you would like to submit a bug report, please visit:
>>>> #   http://bugreport.sun.com/bugreport/crash.jsp
>>>> # The crash happened outside the Java Virtual Machine in native code.
>>>> # See problematic frame for where to report the bug.
>>>> #
>>>>
>>>> I've tried OpenJDK and Oracle JDK.
>>>>
>>>
>>> what version of java? you could try adding an unsupported ppa to add a
>>> potentially newer version http://www.ubuntuupdates.org/ppa/webupd8_java
>>>
>>> could be that tuxguitar needs an older version. what does tux guitar
>>> report requiring? what are the error messages in the terminal if you use
>>> the terminal to run the application and get it to crash?
>>>
>>>
>>>>
>>>>
>>>> grtz,
>>>>
>>>> Bart
>>>>
>>>> http://www.bartart3d.be/
>>>> On facebook <https://www.facebook.com/pages/BartArt3D/169488999795102>
>>>> On Twitter <https://twitter.com/#%21/Bart_Issimo>
>>>> On Identi.ca <http://identi.ca/bartart3d>
>>>> On Google+ <https://plus.google.com/u/0/b/116379400376517483499/>
>>>>
>>>>
>>>> 2013/11/14 Mike Holstein <mikeh789 at gmail.com>
>>>>
>>>>>
>>>>>
>>>>>
>>>>> On Thu, Nov 14, 2013 at 11:46 AM, bart deruyter <
>>>>> bart.deruyter at gmail.com> wrote:
>>>>>
>>>>>> Hi all,
>>>>>>
>>>>>> I'm experiencing quite some issues with tuxguitar. When wanting to
>>>>>> change some settings, it always crashes.
>>>>>>
>>>>>> More specifically when I click on 'Skins' or 'Sound' it always
>>>>>> crashes. Especially the 'Sounds' section of the settings is important, but
>>>>>> I can't access it this way.
>>>>>>
>>>>>> Anyone else experiencing this issue, maybe even with a fix?
>>>>>>
>>>>>
>>>>> i personally havent used it.. can you start the application from the
>>>>> terminal and get any specific error messages from the crashes? is this with
>>>>> JACK? do you see any relevant JACK messages? does the crash cause
>>>>> JACK/pulse to crash? or is it the other way around?
>>>>>
>>>>>
>>>>>>
>>>>>> Grtz,
>>>>>>
>>>>>> Bart
>>>>>> http://www.bartart3d.be/
>>>>>> On facebook<https://www.facebook.com/pages/BartArt3D/169488999795102>
>>>>>> On Twitter <https://twitter.com/#%21/Bart_Issimo>
>>>>>> On Identi.ca <http://identi.ca/bartart3d>
>>>>>> On Google+ <https://plus.google.com/u/0/b/116379400376517483499/>
>>>>>>
>>>>>> --
>>>>>> ubuntu-studio-users mailing list
>>>>>> ubuntu-studio-users at lists.ubuntu.com
>>>>>> Modify settings or unsubscribe at:
>>>>>> https://lists.ubuntu.com/mailman/listinfo/ubuntu-studio-users
>>>>>>
>>>>>>
>>>>>
>>>>>
>>>>> --
>>>>> MH
>>>>>
>>>>> mikeholstein.info <http://www.mikeholstein.info/>
>>>>>
>>>>>
>>>>> --
>>>>> ubuntu-studio-users mailing list
>>>>> ubuntu-studio-users at lists.ubuntu.com
>>>>> Modify settings or unsubscribe at:
>>>>> https://lists.ubuntu.com/mailman/listinfo/ubuntu-studio-users
>>>>>
>>>>>
>>>>
>>>> --
>>>> ubuntu-studio-users mailing list
>>>> ubuntu-studio-users at lists.ubuntu.com
>>>> Modify settings or unsubscribe at:
>>>> https://lists.ubuntu.com/mailman/listinfo/ubuntu-studio-users
>>>>
>>>>
>>>
>>>
>>> --
>>> MH
>>>
>>> mikeholstein.info <http://www.mikeholstein.info/>
>>>
>>>
>>> --
>>> ubuntu-studio-users mailing list
>>> ubuntu-studio-users at lists.ubuntu.com
>>> Modify settings or unsubscribe at:
>>> https://lists.ubuntu.com/mailman/listinfo/ubuntu-studio-users
>>>
>>>
>>
>> --
>> ubuntu-studio-users mailing list
>> ubuntu-studio-users at lists.ubuntu.com
>> Modify settings or unsubscribe at:
>> https://lists.ubuntu.com/mailman/listinfo/ubuntu-studio-users
>>
>>
>
>
> --
> MH
>
> mikeholstein.info <http://www.mikeholstein.info/>
>
>
> --
> ubuntu-studio-users mailing list
> ubuntu-studio-users at lists.ubuntu.com
> Modify settings or unsubscribe at:
> https://lists.ubuntu.com/mailman/listinfo/ubuntu-studio-users
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.ubuntu.com/archives/ubuntu-studio-users/attachments/20131126/ad768ace/attachment.html>


More information about the ubuntu-studio-users mailing list