[ubuntu-studio-users] GLX problem

David King linuxman at avoura.com
Sat Dec 7 21:09:08 UTC 2013


  Hi all,

I am currently having a problem with all things GLX related, i.e. 
screensavers that use GLX are no longer working, also a game that uses 
GLX. E.g. when running foobillard in terminal I get the following error:

     main:rgstereo=0Video mode set failed: Couldn't find matching GLX visual

It used to work fine, running from the main menu. But now it's failing 
to find the right GLX visual. I get the same thing for screensavers,

    Xlib: extension "GLX" missing on display ":0.0"

This line is displayed several times on the screen instead of the 
screensaver, and the last bit says it exited abnormally (code 1)


I wonder if this is Flash/Gnash related? I recently found that Firefox 
was running extremely slowly on any site with Flash elements, so I 
removed Flash (I have heard it is very troublesome at times to some 
Linux users) and installed Gnash instead. Firefox works much better, and 
also with Flash-blocking add ons so that I only allow certain sites to 
use Flash.

I am not sure if the GLX problem occurred before or after this.

My Desktop is XFCE on Ubuntu Studio 12.04

Of course it might also have been a recent update that might have 
knocked out GLX.

In using Synaptic I see that the GLX stuff is still installed. I tried 
reinstalling some of it, but it made no difference.

I am using the Linux open source graphics driver for my graphics card, 
nothing proprietary. It is an AMD card.


So how do I get GLX working again?


David K





-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.ubuntu.com/archives/ubuntu-studio-users/attachments/20131207/cf63a0da/attachment.html>


More information about the ubuntu-studio-users mailing list