(rant) Is there any hope

Hartmut Noack zettberlin at linuxuse.de
Sat Mar 3 20:03:34 UTC 2012


Am 03.03.2012 20:40, schrieb saearea-test at yahoo.com:
>
>
>
>
>
>> ________________________________
>> Von: Hartmut Noack<zettberlin at linuxuse.de>
>> An: ubuntu-studio-users at lists.ubuntu.com
>> Gesendet: 12:24 Samstag, 3.März 2012
>> Betreff: Re: (rant) Is there any hope
>>
>> Am 03.03.2012 07:45, schrieb Jose H.:
>>> So, if I ready correctly:
>>
>> It would be much easier to find out, what it is, that you read, if you
>> would not top-post but point us to what you are talking about.
>>
>>>
>>> Ubuntu Studio is not, and will not be a productive audio recording and
>>> mixing environment.
>>> Why:
>>>         1) kernel issues
>>>         2) driver issues
>>
>> All this applies to Ubuntu Studio in some cases with some combinations
>> of hardware. It does not apply to many other Linux-Variants, including
>> Ubuntu-derivates like KXStudio. And as far as I am concerned, it does
>> not apply to my setup, that simply works perfectly well with Ubuntu plus
>> the KX-Layer. And so does my Laptop. And my USB-interface and my
>> Firewire-interface.
>>
>> Sorry folks, I really cant help but say: it works for me, just great.
>> It does for about 8 years now, with maybe a dozen different machines and
>> soundcards. And for some friends of mine it does so as well.
>>
>>
>>>
>>> Options:
>>>         1) Use a new distro that some say is great !  ( a new clone of
>>> ubuntu/debian/etc.. ) - not really a good option
>>
>> Fedora, Suse, Debian vanilla: I made music with all of them, with bands,
>> for video everything everybody does with music on computers, all did
>> work OK for me. And yes: some did work for setups Ubuntu failed to
>> support the same as good.
>>
>>>         2) Just install Windows and be able to do some of the stuff, maybe all
>>> you need    - realistic option
>>
>> Do, as thou wishest but please consider to accept, that Linux did not
>> work for *you* and *your* setup. It does work for many others.
>>
>>>         3) Wait until Linux has a decent Sound API           - unrealistic
>>> option
>>
>> I do not really understand, what you mean by "a decent Sound API"  Jack
>> and ALSA are consolidated and seam to work (last time I checked I found
>> a few hundred applications and devices that worked good with these
>> APIs). And everything else, that may exist in Linux regarding sound is
>> irrelevant for musicians (and it does not interfere anymore either).
>>
>>>
>>> Well, that conclusion is sound with my own experience.
>>
>> *Your own* experience -- thanks for pointing to this.
>>
>>> Ubuntu/Linux is
>>> supposed to be better than other OSs but definitely music production is not
>>> one of those fields in which it gets even to the minimum expected.
>>
>> In *Your own* experience it may be so. BTW: what other Linux-Variants
>> did you test? Fedora+CCRMA? Pure:Dyne? Suse?
>>
>>
>>>
>>> Personally I think this is because we don't have a firm base to build. You
>>> can't expect to have great user apps if you can't even have a good OS
>>> layer. Even if you have great apps, for what if you can't get the OS to
>>> work !?. We have ZynAddSubFX, but your sound card just doesn't work !
>>
>> What if you have Logic on your IBook running MacOSX but alas! Your
>> interface does not come with a driver compatible to that version of MacOSX?
>>
>> Try Google, chances are, you find more than one thread discussing such
>> issues, lesser chance though, that such threads end with the conclusion,
>> that MacOSX would be entirely unusable for musicians....
>>
>>
>>> , why
>>> ?, maybe because pulseaudio, maybe because the driver, maybe because the
>>> kernel or maybe because the modules you load ?, or maybe because you are
>>> not tired of linux and you just want to play and forget about Ubuntu Studio.
>>
>> I recommend indeed to abandon Ubuntu Studio and try Fedora or Suse.
>>
>> best regards
>>
>> HZN
>>
>>>
>>> Regards
>>>
>>>
>>>
>>> El 18 de febrero de 2012 06:04, teza<tezalprod at gmail.com>   escribió:
>>>
>>>> Hi
>>>> Should try.Tango Studio
>>>> Regards
>>>> Teza.
>>>> Le 15 févr. 2012 05:11, "Rick Green"<rtg at aapsc.com>   a écrit :
>>>>
>>>> for Ubuntu Studio as a productive audio recording and mixing environment?
>>>>>
>>>>> Four years ago, I bought a Focusrite Saffire Pro 26 firewire interface,
>>>>> largely because it was listed as one of the best-supported by the ffado
>>>>> project.  I loaded up a copy of UbuntuStudio 8.04LTS.  The clean install
>>>>> wouldn't talk to the interface, but after I obtained a bleeding-edge copy
>>>>> of the ffado source from one of the developers, and recompiled locally, I
>>>>> was up and running.  I've used that installation for every recording I've
>>>>> done since.  For the most part it's stable, and I've learned to work-around
>>>>> its quirks
>>>>>     When 10.04 came out, I thought I'd upgrade, thinking I'd like to see the
>>>>> latest enhancements to Ardour, and it might be more forgiving of the order
>>>>> I start up programs.  But 10.04 wasn't stable enough to run jack for more
>>>>> than a few minutes before the xrun count went thru the roof.
>>>>>     Since then, I've tried every new release, and the regressions are
>>>>> stacking up faster than ever.
>>>>>
>>>>>     I recently did a clean install of 11.10 (amd64), and tonight gave it a
>>>>> first attempt with the firewire interface...
>>>>>
>>>>>     With 8.04, I start ffado-mixer, and it automatically starts the
>>>>> ffado-dbus-server.  With this one, it merely complains that the dbus server
>>>>> isn't running, so I'm forced to open a terminal and start it, then when I
>>>>> restart ffado-mixer, it tells me 'no supported devices found'.
>>>>>     This isn't exactly true, for when I go to a terminal and run ffado-test
>>>>> ListDevices, it clearly finds my focusrite pro26IO on node 1.
>>>>>
>>>>> I launch qjackctl, open the setup window, and select the firewire driver,
>>>>> accepting all the defaults for now.  When I attempt to start jack, it fails
>>>>> with a 'cannot connect to server as client' message.
>>>>>
>>>>> After many attempts and reboots, I discover that if I start qjackctl and
>>>>> start jack without attempting to start ffado-mixer or ffado-dbus-server
>>>>> first, then jack will actually start! (With 8.04, I HAD to start
>>>>> ffado-mixer first.)
>>>>>     I launch Ardour, open a new session, and start to record two tracks of
>>>>> whatever audio happened to be playing on the stereo at the time.  About 24
>>>>> minutes later, just as I'm getting complacent with no xruns recorded(!),
>>>>> jack inexplicably dies, but qjackctl doesn't know it, so it is locked up,
>>>>> too.  I ended up having to go back to the terminal and kill -9 everything
>>>>> jack-related I could find, then power down my interface, and power it back
>>>>> on, then restart qjackctl, and finally jack.  Only then could I tell Ardour
>>>>> to reconnect and save the session, but for some reason Ardour's transport
>>>>> was messed up.  I could move the playhead either directly, or with the |<<
>>>>> button, but the 'Big Clock' still showed the time at the end of the aborted
>>>>> capture, and the 'play' button or the spacebar had no effect.
>>>>>     I closed Ardour, then went to stop jack and close qjackctl, and qjackctl
>>>>> threw messages about a client still connected (Ardour was already shut down
>>>>> at this point), and after I press the 'close anyway' button, then qjackctl
>>>>> itself refuses to quit cleanly, and I get a 'program not responding'
>>>>> message from the window manager, and I'm forced to go back to the terminal
>>>>> and resort to kill -9 again.
>>>>>
>>>>>     The developers are over halfway into the 12.04 cycle now, so I don't see
>>>>> any point in submitting bug reports against 11.10 for all this.  Have they
>>>>> gotten to the point of publishing any pre-builds of 12.04, and would it be
>>>>> any help to install that and submit bugs against 12.04pre- instead?
>>>>>
>>>>> --
>>>>> Rick Green
>>>>>
>>>>> "Those who would give up essential Liberty, to purchase a little
>>>>> temporary Safety, deserve neither Liberty nor Safety."
>>>>>                                     -Benjamin Franklin
>>>>>
>>>>> "As for our common defense, we reject as false the choice between our
>>>>> safety and our ideals."
>>>>>                                  -President Barack Obama 20 Jan 2009
>>>>>
>>>>> --
>>>>> Ubuntu-Studio-users mailing list
>>>>> Ubuntu-Studio-users at lists.**ubuntu.com<Ubuntu-Studio-users at lists.ubuntu.com>
>>>>> Modify settings or unsubscribe at: https://lists.ubuntu.com/**
>>>>> mailman/listinfo/ubuntu-**studio-users<https://lists.ubuntu.com/mailman/listinfo/ubuntu-studio-users>
>>>>>
>>>>
>>>> --
>>>> Ubuntu-Studio-users mailing list
>>>> Ubuntu-Studio-users at lists.ubuntu.com
>>>> Modify settings or unsubscribe at:
>>>> https://lists.ubuntu.com/mailman/listinfo/ubuntu-studio-users
>>>>
>>>>
>>>
>>>
>>>
>>>
>>
>>
>> --
>> Ubuntu-Studio-users mailing list
>> Ubuntu-Studio-users at lists.ubuntu.com
>> Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-studio-users
>>
>>
>> Hello Hartmut,
>>
>> could you post the setup of your systems that have always worked?

PC
with Asus-Board and IntelQuadcore
NVidia-Graphics(prop. drivers)
MAudio Audiophile 2496 (does not work well with PA, perfectly with ALSA 
and Jack. Since KXStudio bridges PA to Jack and starts Jack by default, 
this is no issue to be solved by hand anymore))
Presonus Firebox (trouble can be caused by some FW-Chipsets, works best 
with the built-in of the ASUS)
MAudio mobile Pre USB (Jack needs to be forced to use 16bit)

I use the MAudio mobile with a Thinkpad T60 also, works out of the box 
in Fedora+CCRMA and Suse

best regards

HZN




> Maybe you have done that already and it is available somewhere in an archive or blog, please send me the URL. Thanks in advance.
>>
>> On a different topic.
>> I was getting very tired of listening to the fan noise of my laptop. I had bought an external fan (ZALMAN) onto which I would place the laptop and it was working quite well, but still: noise. Maybe the open source graphics driver wasn't able to control the fan too well.
>> I looked for alternatives and considered several options e.g. server and thin client setup, with a server in a different room. Or a tower PC with extra quite fans.
>>
>> For a couple of days now, working on the PC has become a new sensation. I found a completely fan-less system (http://www.caseking.de/shop/catalog/King-Mod-No-Noise-HTPC-Gigabyte-AMD-APU-E350::17711.html). I've added a Samsung SDD and a 21" LED monitor from AOC. Currently I am running xubuntu 11.10.  I haven't tweaked it yet (e.g. 3D graphics drivers, desktop effects, etc.). I was looking for some nice temperature meter on the desktop for xfce, but I think I need compiz for desktop effects first. So far I have a terminal open with "watch sensors", that keeps me updated on the temperature of the system. On the average it is about 50 degrees Celcius, very similar to what I saw on my laptop with fans.
>> I learned that when using Gigabyte motherboards and trying to boot from USB sticks is not easily accomplished. But thanks to others sharing their solution, I was able to install xubuntu from a USB stick.
>> I am not sure whether the CPU power will be enough for more heavyweight kind of work (e.g. video encoding), but general applications (office, browser) are a breeze.
>> Standby and suspend worked out of the box. Apparently the network card: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 06) can have problems with dual boot Windows (where Windows puts it into sleep during shutdown and the linux driver not being able to wake it up again - or something). I don't have dual boot at the moment, so I cannot comment on that. But I have seen this behavior on a laptop (ASUS, AMD E450) with dual boot .
>> ...
>> and still: no noise :)
>>
>> Just wanted to share.
>>
>> Cheers,
>> Stefan
>>
>>
>>




More information about the Ubuntu-Studio-users mailing list