NetworkManager - Was: Sharing "things" between Ubuntu Studio 11.10 and...

Ralf Mardorf ralf.mardorf at alice-dsl.net
Sun Feb 19 12:13:37 UTC 2012


To get Internet access for my iPad using US 11.10 I now try nm.

I still need help.

On Debian users mailing list
( http://lists.debian.org/debian-user/2012/02/ ) we managed to get it
"semi-working" ;) on US 11.10:

-------- Forwarded Message --------
From: Ralf Mardorf <ralf.mardorf at alice-dsl.net>
To: debian-user <debian-user at lists.debian.org>
Subject: Re: How to share the Internet with Linux and an iPad by Wi-Fi?
Date: Sun, 19 Feb 2012 12:58:19 +0100

On Sun, 2012-02-19 at 02:54 +0200, Andrei POPESCU wrote:
> On Du, 19 feb 12, 01:18:20, Ralf Mardorf wrote:
> > Tab "IPv4 Settings"
> > Method: Manual
> 
> This is the setting you need to change, but I don't know how it's
called 
> in English. The Romanian translation would suggest something like 
> "Connection sharing".
> 
> Hope this helps,
> Andrei

Yes, thank you, it's "Shared to other computers". I edited it by using
nm-connection-editor, after that the nm-applet appeared automatically
and after enabling wireless, the applet showed networks from my
neighborhood. After a while the Linux network was shown by the iPad,
then I lost the connection. I disabled and enabled wireless, but nothing
happened.

I'll reboot. I still wonder, if I need to set addresses and what
username and password to use.

Settings now are:

Connection name: Wireless connection 1
        [x] Connect automatically
        [x] Available to all users
        Tab "Wireless"
        SSID: oz
        Mode: Ad-hoc
        Band: Automatic
        (Channel: default)
        BSSID:
        Device MAC address:
        Cloned MAC adresse:
        MTU: automatic
        Tab "IPv4 Settings"
        Method: Shared to other computers
        (Adress:
        Netmask:
        Gateway:
        DNS servers:
        Search domains:
        DHCP client ID:)
        [x] Require IPv4 addressing for this connection to complete
        (Nothing edited for "Routes...")
        Nothing edited for tab "IPv6 Settings"
        Tab "Wireless security"
        Security: WE 128-bit Passphrase
        Key: 1234567890

I only enabled wireless, the DSL connection isn't set up by nm, it was
set up by pppoeconf and starts automatically at startup.

After rebooting the nm-applet appeared automatically and a notification
is displayed:
"Network

Disconnected - you are offline"

Anyway I can surf the Internet using Firefox, but indeed, Evolution
can't connect.

I enabled networking. Evolution now is connected. Wireless isn't
enabled, but the neighborhood's networks are shown by the applet. The
iPad shows the Linux network oz. Again and again authentication is
required by Linux. I'm always using "1234567890" and then always push
connect. After a while, when I tried to set up the iPad, the network
"oz" can't be found anymore, the USB adapter's LED indeed change it's
notification flashing. Enabling wireless doesn't change anything.

I still wonder what settings I have to do for the iPad, username,
password, of my provider? "oz" and this "1234567890" key? I'll change
it, when it's working ;).

I'll backup the install now and continue later.

Regards,
Ralf

-------- Forwarded Message --------
From: Ralf Mardorf <ralf.mardorf at alice-dsl.net>
To: debian-user <debian-user at lists.debian.org>
Subject: Re: How to share the Internet with Linux and an iPad by Wi-Fi?
Date: Sun, 19 Feb 2012 13:12:55 +0100

PS:
After a while I'm asked again and again for authentication by Linux and
the USB adapters LED shows that it's sending again, but some time later
it gets lost again.




More information about the Ubuntu-Studio-users mailing list