diagnostic tools to trace the reason xruns are happening?

bart deruyter bart.deruyter at gmail.com
Wed Jun 22 17:24:01 UTC 2011

Hi guys,

I've found something interesting, which showed some issues on my system. I
haven't tried to fix the issues yet, because I'm curious about what you all
would think about it.

I've found a diagnostic tool, while exploring the fedora website. Perhaps
this could be of some use for the new ubuntustudio controls. Perhaps the app
could be a basis to start with. At least it is good for inspiration :-)


Is it something interesting?

When I run it, it shows that the kernel is ok, but that there is no access
for the audio group to the high precision event timer, nor for the real-time
clock. Also there seems to be way too much swap, larger then 10, apparently
according to the app, it should be 10. It shows links to the linuxmusicians
wiki for solving these issues.



2011/6/6 Mac <macdroid53 at gmail.com>

> On Mon, Jun 6, 2011 at 9:23 AM, Mike Holstein <mikeh789 at gmail.com> wrote:
> > i'll top post and say again, with my presonus firepod in 10.04 with
> > -realtime kernel i can do under 5ms latency stable, and depending on what
> im
> > doing (if its not too intensive) i can do 1.2ms stable. stable for me is
> > *no* xruns (except maybe when opening an application, but never idle
> xruns
> > popping up).
> Same criteria for me with two AF12's and 10.04. (Though latency was
> not an issue since it was record only)
> As I've mentioned previously, I've had similar results with AVLinux
> 4.2 which uses the Liquorix Kernel.
> --
> Ubuntu-Studio-users mailing list
> Ubuntu-Studio-users at lists.ubuntu.com
> Modify settings or unsubscribe at:
> https://lists.ubuntu.com/mailman/listinfo/ubuntu-studio-users
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.ubuntu.com/archives/ubuntu-studio-users/attachments/20110622/1076ebac/attachment.html>

More information about the Ubuntu-Studio-users mailing list