Real time for Ubuntu Studio 10.04 amd64

Ralf Mardorf ralf.mardorf at alice-dsl.net
Mon Jul 12 12:32:05 BST 2010


Hi Oleg :)

On Mon, 2010-07-12 at 14:59 +0400, Oleg Ivanenko wrote:
> 
> 2010/7/12 Ralf Mardorf <ralf.mardorf at alice-dsl.net>
>         
>         
>         What's bad with this posting? This is my question:
>         
>         >         I wonder what I need to do, to get a kernel-rt for
>         >         Ubuntustudio 10.04?
>         
>         
> 
> 
> Hi, Ralf!
> 
> 
> Check this link http://ubuntustudio.org/LucidLynx and find phrases
> "https://launchpad.net/~abogani/+archive/ppa" and "realtime kernel
> will be available in Ubuntu Studio PPA" in the text. May be this info
> will help you.

Thank you, unfortunately 2.6.33-23-realtime amd64 results with 'ACPI:
Expecting a [Reference] package element, found type 0' and a login for
text mode. FWIW I didn't log in and tested to start x or gdm.

> Personally I have installed(default Ubunto Studio meta-package
> linux-rt):
> linux-image-2.6.31-11-rt
> Linux kernel image for version 2.6.31 on Ingo Molnar's full real time
> preemption patch

This is one of the kernels that stops booting with the message 'mount:
mounting none on /dev failed: No such device.'

Is your machine an AMD dual core too and is the architecture of your 64
Studio also amd64, but x86?

Perhaps it has to do with the NVIDIA graphics? Perhaps I should generate
a xorg.conf by running 'sudo X -configure' and test the vesa driver. I
dunno.

The eye-catching thing regarding to 'mount: mounting none on /dev
failed: No such device.' is

# cat config-2.6.31-11-rt | grep CONFIG_DEVTMPFS
# cat config-2.6.32-23-preempt | grep CONFIG_DEVTMPFS
CONFIG_DEVTMPFS=y
CONFIG_DEVTMPFS_MOUNT=y

that there's no output for 2.6.31-11-rt.

- Ralf





More information about the Ubuntu-Studio-users mailing list