Trying to install lucid beta on a SCSI box, attempt 2

Thomas Orgis thomas-forum at
Tue Apr 6 23:14:14 BST 2010

Ok, then... I am trying to control my rage... and extract some useful information of my day with ubuntu.
This day. This night.

I followed the advice to install normal ubuntu first, then add the ubuntustudio stuff. That way, I hoped to get the standard stuff like network management including 3G dialup. Well... that is about true ... but what I also got was a bunch of new experienes.

1. First Install

I booted the ubuntu ludic beta1 live CD... did a straight forward install (just manually selecting the partition to install to). This one manages to setup up a boot manager correctly... plus, it's able to download language packages from the internet through the configured 3G dialup. Even smart enough to copy the dialup config to the installed system.
I had to add rootdelay=90 to the boot command line because of the well-known (???) bug of SCSI disks not being found in time, but I expected that. Still sucks... I wonder if this is some bug specific to ubuntu or just an effect of having the SCSI driver as module with modern kernels.

Then, in the booted fresh install, I popped in the ubuntustudio DVD and followed the popup window about accessing that medium as package source with synaptic. Selected the ubuntustudio profile packages... and let it grab a load of stuff from the net, too. This took some time, with the dialup not being that broad banded (about 250 MiB with about 30K/s).

1.1 Known issue: Bad resolution

This is fine with plain ubuntu but bad with ubuntu studio: The automatic X11 setup uses a bad resolution. After switching to the ubuntu studio kernel (I assume X11 is not changed), the system wants to run my 15 inch TFT with 1366x768 resolution (I think it was this widescreen res, to big in any case) instead of 1024x768. I knew that from my first install, so I quickly had /etc/X11/xorg.conf created with a fixed set of resolutions. Of course that sucks when we replace the monitor and I have to rember to adapt/delete the xorg.conf ... the default does not work.
Bug report needed for this one? Possible that this issue goes away when updating the kernel to 2.6.33-rt10 or so... (I am still wondering if I should install a custom kernel after all ... to include the SCSI driver and hope for reduced rootdelay).

1.2 Big Bad Breakage

Now... the crashing plymouth kept nagging me (would a system update really fix this now? -- I need to see if my next visit at the box is long enough for the downloads). It's main function seems to be nagging (and irritate newbies), so I decided to rip plymouth out. Due to a dangerous fling, I clicked on the Software Center menu entry.
Searched for "plymouth" ... removed the daemon... seen that there still is a package for plymouth shared libs... wondered how much stuff might depend on it... figured that one will get warnings about removing dependent stuff (like synaptic does it)... deleted it.
B-O-O-M! X11 is killed ... I manage to activate a plain console ... and see that I unwittingly entered a major system fubar.
Tried to restart gdm ... there is no gdm ... tried to look after the binary... there is no /bin/ls! Wow. There even is no halt, reboot or shutdown. This system is really ripped apart for good.

This is something one really would like to avoid happening to new users, old users ... anyone. This Software Center thingie is supposed to be the bubbly-touchy-feely admin interface for Linux newbies / notcarealots, right? I consider it a serious bug that it hoses the whole install beyond repair for any average ubuntu user (well, except for reinstall). Is this something known? Shall I make a flaming report on launchpad?

2. Second Install

Since the system was still pretty vanilla (before the blow-up), I rather decided on starting from scratch, reinstall ubuntu, add ubuntu studio on top again. This time I wanted to avoid waiting hours for downloads, so I saved /var/cache/apt/archives and shoved it back once the basic system was installed. That worked nicely... but what didn't work was the install of archives from the ubuntu studio DVD.

2.1 Aptstinence

A first time, the familiar popup about package source CDROM (well, or DVD) being inserted appeared and made me install the first part of ubuntu studio (the desktop stuff, AFAIR). But then, after adjusting the boot config for the rt kernel and restarting... that darned popup did not pop up again. So I tried to manually make synaptic use the DVD. No gain for much pain. When wanting to add a CDROM source, it complains that it cannot mount the cdrom. Also apt-cdrom seems to be confused, too. It might have something to do with the system having too many CD/DVD drives (2 real ones, one virtual from the Huawei E160 modem)... or rather with the automagic mounting system.
I have seen that the media was mounted under "/media/Ubuntu-bla-bla_", not under "/media/Ubuntu-bla-bla" ... both directories exist. Maybe synaptic expected the latter mount point while the disc is accessible under the former.

I finally was able to fool apt/synaptic into using the medium via a custom mount point and using that as a "file" type resource instead of cdrom in apt sources list. But the time until getting that hack out for sure made me furious with ubuntu. You can be thankful for me needing a day to finish this post... I don't remember all the colorful words that I might have used not long ago.

Well, then... now I got the stuff installed... back to bugs.

2.2 MeTube?

After some fiddling around with permissions I finally managed to start jackd using my firewire box. Pro audio might work -- that as a side note. But that mostly works on the other "scary" Linux system, too (reliability, we'll see).
Now I wonder about getting all audio routed out to jackd, since the internal audio is not wired up to any speakers. I decided to kick out pulseaudio... for lack of benefit. I'll go for an asoundrc that uses the jack plugin, possibly created on startup with qjackctl, or just a fixed one.

Well, I was surprised that the video player, totem, just used the jackd without any special config. What was cool. It just works. I also spotted that special YouTube support in Totem... and promptly am disappointed by it not playing the videos becaus of some gstreamer library error. The issue seems to be reported in launchpad, but no resolution in sight. Too bad. Now I rather would like a way to hide the Youtube functionality from totem... I'd hate to tell my collegues that "Yeah, that feature is there... but it does not work."

2.3 What did I forget?

Hm. That is it for now... The system is still there... halfway ready for usage... I'll visit it again soon. Perhaps it can be turned into a workable studio system ... and maybe it can lessen the cries for Windows ... but I am a bit pessimistic on that front. It's still different. It has different bugs, at least.

It would be nice if you folks would point out the parts of my report that should be turned into new launchpad tracker items...

Alrighty then,


-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 197 bytes
Desc: not available
Url : 

More information about the Ubuntu-Studio-users mailing list