Problems with Hercules USB DJ Console drivers and the real-time kernel

Alex Langberg alexlangberg at
Wed Sep 23 22:26:52 BST 2009


I've been messing around lately with a Hercules USB DJ Console Rmx.
Hercules has provided Linux drivers in a .deb package that works
flawlessly with the standard kernel. However, I'd really like to get
the low latency of the real-time kernel. This is what happened when I

1. I had Ubuntu Studio 9.04 on one machine, with the RT kernel. Same
problem as above, driver seemed to install but did not detect the RMX.
2. Tried it on another machine with Eeebuntu 3.0 (= 9.04, not RT) and
it worked perfectly.
3. Downgraded the first machine to Ubuntu Studio 8.10 (that has no RT
kernel). Once I had installed the driver I noticed that after
restarting, just after the loading screen I would see text on the
screen for a few seconds, that the machine was doing something with
the driver I just installed. Then go to the login. This also worked
4. I then tried to downgrade the first machine again, this time to
Ubuntu Studio 8.04, that has a RT kernel. Once again, this did not

Now, obviously, it seems to me like the driver just won't work with
the RT kernel. If you look at the page for the Linux driver from
Hercules (it's in the bottom), it states somewhere that "3) In
general, the distribution should be set up in order to compile kernel
modules (Notes 1 and 2 above ensure this for Fedora and OpenSuse, and
the other cited distributions should be immediately ready)." and I
think it might have something to do with that.

I'm wondering if maybe:

1) The RT kernel is not setup to compile kernel modules. How do I
know? Do I need to install some packages to enable it?
2) Hercules made the driver in a way such that it only works with the
normal kernel and not the RT?

It seems like I might just need a couple of packages or something so
any help would be appreciated. :)


More information about the Ubuntu-Studio-users mailing list