Jack Crashes With "Bus Error"

Oleg Ivanenko oivanenko at gmail.com
Sun Nov 29 21:49:35 GMT 2009


Hi, James!

I had similar behavior --
https://lists.ubuntu.com/archives/ubuntu-studio-users/2009-November/005617.html

Seems like my situation become slightly better(but not completly
solved) with these rows added in /etc/security/limits.conf

@audio          -       rtprio          99
@audio          -       memlock         unlimited
@audio          -       nice            -19

2009/11/30 James Pollard <pollardjm at gmail.com>:
>
> Hi All,
>
> Have recently installed karmic koala ubuntu studio and have been very happy
> with the overall feel of the system. Got a couple of strange niggles. The
> first is that Jack often won't start either from using QJackctl or from the
> command line. Often it starts up first time, but if it is stopped it won't
> restart until I shut down the computer and start again (loging out doesn't
> help). Starting from the command line gives me a "Bus Error" and no further
> information. I've tried googling this but have not got anywhere.
>
> The sound card I'm using is a USB m-audio MobilePre.
>
> Any ideas appreciated. Not sure where to start with this.
>
> thanks,
> James.
> PS: Command line output below:
> /usr/bin/jackd -R -dalsa -r44100 -p64 -n4 -D -Chw:1 -Phw:1
> no message buffer overruns
> jackd 0.116.1
> Copyright 2001-2005 Paul Davis and others.
> jackd comes with ABSOLUTELY NO WARRANTY
> This is free software, and you are welcome to redistribute it
> under certain conditions; see the file COPYING for details
>
> JACK compiled with System V SHM support.
> loading driver ..
> apparent rate = 44100
> creating alsa driver ... hw:1|hw:1|64|4|44100|0|0|nomon|swmeter|-|32bit
> control device hw:1
> Bus error
>
>
>
>
> --
> Ubuntu-Studio-users mailing list
> Ubuntu-Studio-users at lists.ubuntu.com
> Modify settings or unsubscribe at:
> https://lists.ubuntu.com/mailman/listinfo/ubuntu-studio-users
>
>



-- 
Truly yours, Oleg Ivanenko aka Ash
[if it wasn't so sad, it would be funny]



More information about the Ubuntu-Studio-users mailing list