Jaunty Real Time Kernel fails immediately

Rich E reakinator at gmail.com
Sun May 17 15:50:57 BST 2009


Nope, just tried yours because others seemed to have success.. do you have a
good link to building the kernel in ubuntu?

The problem is that every time I have tried building it myself, either my
wireless card doesn't work, my mouse flips out, or nothing works.... not to
mention it takes me a day or two.

On Sun, May 17, 2009 at 4:46 PM, Luke MacNeil <tcpsyn at gmail.com> wrote:

> Interesting. I have no idea why you'd be getting that error. Did you
> try patching the kernel source yourself?
>
> On Sun, May 17, 2009 at 10:33 AM, Rich E <reakinator at gmail.com> wrote:
> > Hi Luke, list,
> >
> > I tried installing the kernel linked here and got the following error
> from
> > the package installer. Anyone know why?  I only have the standard Jaunty
> > kernel installed, have not tried the rt (because it seems doomed).
> >
> > Rich
> >
> > Here is the error report:
> >
> > Selecting previously deselected package linux-image-2.6.29.1-rt8-custom.
> > (Reading database ... 228217 files and directories currently installed.)
> > Unpacking linux-image-2.6.29.1-rt8-custom (from
> >
> .../linux-image-2.6.29.1-rt8-custom_2.6.29.1-rt8-custom-10.00.Custom_i386.deb)
> > ...
> > Done.
> > Setting up linux-image-2.6.29.1-rt8-custom
> > (2.6.29.1-rt8-custom-10.00.Custom) ...
> >
> >  Hmm. There is a symbolic link /lib/modules/2.6.29.1-rt8-custom/build
> >  However, I can not read it: No such file or directory
> >  Therefore, I am deleting /lib/modules/2.6.29.1-rt8-custom/build
> >
> >
> >  Hmm. The package shipped with a symbolic link
> > /lib/modules/2.6.29.1-rt8-custom/source
> >  However, I can not read the target: No such file or directory
> >  Therefore, I am deleting /lib/modules/2.6.29.1-rt8-custom/source
> >
> > Running depmod.
> > Finding valid ramdisk creators.
> > Using mkinitramfs-kpkg to build the ramdisk.
> > Running postinst hook script update-grub.
> > Searching for GRUB installation directory ... found: /boot/grub
> > Searching for default file ... found: /boot/grub/default
> > Testing for an existing GRUB menu.lst file ... found: /boot/grub/menu.lst
> > Searching for splash image ... none found, skipping ...
> > Found kernel: /boot/vmlinuz-2.6.29.1-rt8-custom
> > Found kernel: /boot/vmlinuz-2.6.28-11-generic
> > Found kernel: /boot/vmlinuz-2.6.27-11-generic
> > Found kernel: /boot/vmlinuz-2.6.27-7-generic
> > Found kernel: /boot/memtest86+.bin
> > Replacing config file /var/run/grub/menu.lst with new version
> > Updating /boot/grub/menu.lst ... done
> >
> > Examining /etc/kernel/postinst.d.
> > run-parts: executing /etc/kernel/postinst.d/dkms
> > run-parts: executing /etc/kernel/postinst.d/nvidia-common
> > run-parts: /etc/kernel/postinst.d/nvidia-common exited with return code
> 20
> > Failed to process /etc/kernel/postinst.d at
> > /var/lib/dpkg/info/linux-image-2.6.29.1-rt8-custom.postinst line 1186.
> > dpkg: error processing linux-image-2.6.29.1-rt8-custom (--install):
> >  subprocess post-installation script returned error exit status 2
> > Errors were encountered while processing:
> >  linux-image-2.6.29.1-rt8-custom
> >
> >
> >
> > On Sun, Apr 26, 2009 at 3:56 PM, Luke MacNeil <tcpsyn at gmail.com> wrote:
> >>
> >>
> >> On Sat, Apr 25, 2009 at 3:39 PM, Kjel Anderson <kjel.anderson at gmail.com
> >
> >> wrote:
> >>>
> >>> Susan,
> >>>
> >>> I updated your bug report. There was someone in IRC who was having the
> >>> same problem. Do you know what motherboard you have? This fellow on
> >>> IRC and I had the exact same model.
> >>>
> >>> Kjel
> >>>
> >>> On Sat, Apr 25, 2009 at 12:29 PM, Susan Cragin
> >>> <susancragin at earthlink.net> wrote:
> >>> >>Hey list,
> >>> >>
> >>> >>I'm sorry I don't have more information. There doesn't seem to be any
> >>> >>log information generated. I can't find anything on Google. The real
> >>> >>time kernel in Ubuntu Studio jaunty is failing immediately. It is
> >>> >>puking a lot of characters, but I had a hard time seeing a coherent
> >>> >>error message. If anyone can point me to a thread about this I would
> >>> >>be appreciative. I haven't tried any kernel parameters yet.
> >>> >>
> >>> >>Thanks,
> >>> >>
> >>> >>Kjel
> >>> >
> >>> > It does the same for me and I will help if I can.
> >>> > Also filed a bug with Ubuntu. #366352.
> >>> > I eventually booted into Recover, dropped to the prompt with
> internet,
> >>> > and loaded the generic kernel.
> >>> > sudo apt-get install linux
> >>> > Then booted from that into Studio. Perhaps booting into RT and then
> >>> > re-booting into the generic one and reading the old log file?
> >>> > I'll give it a go.
> >>> > Sound had some problems under generic kernel. Have sound setting been
> >>> > changed? Alsa wrappers?
> >>> > Susan
> >>> >
> >>> >
> >>> >
> >>> > --
> >>> > Ubuntu-Studio-users mailing list
> >>> > Ubuntu-Studio-users at lists.ubuntu.com
> >>> > Modify settings or unsubscribe at:
> >>> > https://lists.ubuntu.com/mailman/listinfo/ubuntu-studio-users
> >>> >
> >>>
> >>> --
> >>> Ubuntu-Studio-users mailing list
> >>> Ubuntu-Studio-users at lists.ubuntu.com
> >>> Modify settings or unsubscribe at:
> >>> https://lists.ubuntu.com/mailman/listinfo/ubuntu-studio-users
> >>
> >> I was having this problem. I was able to roll an RT kernel that works. I
> >> threw it up on my webserver if anyone needs it, but I don't have much
> for
> >> bandwidth, so if someone could toss this somewhere, it'd be great.
> >>
> >>
> >>
> http://www.lukemacneil.com/linux-headers-2.6.29.1-rt8-custom_2.6.29.1-rt8-custom-10.00.Custom_i386.deb
> >>
> >>
> >>
> http://www.lukemacneil.com/linux-image-2.6.29.1-rt8-custom_2.6.29.1-rt8-custom-10.00.Custom_i386.deb
> >>
> >> If you install vanilla jaunty, use this kernel, and then install the
> >> ubustu metapackages from the repos, all is well.
> >>
> >>
> >> --
> >> Luke MacNeil
> >> www.lukemacneil.com
> >>
> >> --
> >> Ubuntu-Studio-users mailing list
> >> Ubuntu-Studio-users at lists.ubuntu.com
> >> Modify settings or unsubscribe at:
> >> https://lists.ubuntu.com/mailman/listinfo/ubuntu-studio-users
> >>
> >
> >
>
>
>
> --
> Luke MacNeil
> www.lukemacneil.com
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: https://lists.ubuntu.com/archives/ubuntu-studio-users/attachments/20090517/29157f03/attachment-0001.htm 


More information about the Ubuntu-Studio-users mailing list