Jaunty -RT testing

Eric Hedekar afterthebeep at gmail.com
Wed Mar 11 00:06:01 GMT 2009

On Tue, Mar 10, 2009 at 6:22 AM, Cory K. <coryisatm at ubuntu.com> wrote:

> Cory K. wrote:
> > *This thread for feedback and issues for Jaunty's development -RT kernel*
> >
> > So the new -RT packages are starting to hit the Jaunty archive.
> > Currently only AMD64 has hit.
> >
> > No LRM or linux-rt meta yet. We're waiting on the packages to be
> processed.
> >
> > So if you are running Jaunty-AMD64 and use free drivers: "sudo apt-get
> > install linux-image-2.6.28-1-rt" should get you a working kernel. If you
> > are one of those lucky few for now, please report any issues *aside*
> > from what has already been mentioned in *this thread only*.
> The lack of a response is a little disheartening. I do not believe no
> news is good news. ;)
> In any case, -RT has now hit for 386. Still no LRM yet but those on
> Intel should be fine.
> sudo apt-get install linux-image-2.6.28-2-rt
> Please report any issues. Performance or otherwise. Especially those who
> were saying that they were getting good results with -generic.
> -Cory K.

So after a morning of runing the i386 2.6.28-2-rt kernel I give it a totally
subjective rating of 'moderately unstable' and totally not release ready.
First, I think it's valid to mention my hardware specs and that all my
drivers did work.  I run a AMD Turion single core 1.4ghz (or so) processor,
2gig ram, ATI RadeonXPress200m video card (running open source drivers),
Broadcom 43xx wireless chipset, Presonus Firepod soundcard (running FFADO).
Desktop effects are turned on and running smoothly (less smoothly with the
rt kernel than vanilla, but still smooth)

I ran four 'real world' tests:

1. Basic use, left on overnight, continued basic use (included web browsing,
compiling some programs, running gdb, etc...).  No audio use.  This test
resulted in a catastrophic freeze after about three hours of basic use in
the morning.  I was browsing Youtube videos in Epiphany-browser at the time;
gedit had a few files open, and gdb was sitting idle with firefox at a
breakpoint.  First epiphany 'greyed out', then would not close, then the
keyboard became unresponsive and after waiting a bit, I killed everything by
holding down the power switch.  No particular action sparked this freeze
from what I could tell.

2. Strenuous use while running audio.  I started jack with realtime enabled,
44100, 256, verbose messages, then proceeded to try to make an XRun by
opening a detailed Ardour session (many files, automation, etc...), a rack
of effects, a PD patch that involved audio analysis, Hydrogen,
OpenOffice.org writer, and moving between things via gnome-do docky.  This
test continued for at least 10-15min probably more like 20 and I only
experienced one XRun, however eventually some programs became greyed out
(hydrogen was first, followed by Ardour and Qjackctl) and unresponsive.  I
tried killing (not just ending process, but killing) these processes via
gnome-system monitor but that just led to it being greyed out too.  Tried to
shut down via gnome menu but it did nothing (no shutdown/reboot/suspend
dialog) and not long after, the keyboard became non-responsive.  I waited,
then finally killed the computer via the power switch.

3. Prolonged dedicated recording session.  I setup a stereo pair of mics,
jackd -R, 44100, 256, an Ardour session with a single stereo track, start
Jamin (just to add a touch of processing weight) and put it in between the
mics and Ardour's capture, hit record and wend for a shopping trip.  Two and
a half hours later I came back to a fully recorded track, only 5 XRuns (one
@ 2min in, the other four in the last half-hour - the last was right at the
end, so barely counts).  This is a much lower XRun rate than I was getting
with vanilla kernel, so the rt did positively affect this test.  I thought
"Okay, success!!" so I quit Jamin, then moved to Ardour, pressed Ctrl+Q and
Ardour greyed out along with qjackctl.  I waited and waited, coiled some
cables, thinking well that's a big chunk of data to
close/deallocate/whatever  I'll give it some time, but no - it didn't need
any time.  A few minutes later I tried opening gnome-system monitor, a
terminal, and even epiphany, but all did not open.  I moved to a non-X
(tty3) login, tried sudo init 6 but it failed to turn off - chose to kill
the computer with the power switch.

4. Boot, open gnome-terminal, run uname -r, exit, shutdown.  This test went
off with no hickups, perfect success.

I'd be happy to dig up any logs that people would like to point me to (but
I'm very unfamiliar with the log system) - just direct me where.

-Eric Hedekar

-------------- next part --------------
An HTML attachment was scrubbed...
URL: https://lists.ubuntu.com/archives/ubuntu-studio-users/attachments/20090310/c646bd4f/attachment.htm 

More information about the Ubuntu-Studio-users mailing list