Problems with Video Drivers

Gustin Johnson gustin at
Wed Sep 17 20:06:29 BST 2008

Hash: SHA1

Brian Blater wrote:
> I have an older machine that has been running Ubuntu Studio 7.10 for
> awhile. For the last couple of days I've been trying to install US
> 8.04 on this box (clean install.) For the most part the install went
> fine, but I'm only getting 800x600 resolution from my card - Geforce2
> MX400 using the default driver. I installed the proprietary nvidia
> drivers using the driver manager that pops-up and tells that their are
> proprietary drivers available and then I end up with only 640x480
> after the reboot. Can't seem to get any better. I did some google
> searching and it seams others have had the same problems. No real fix
> for it from what I can tell. Several were able to get it working after
> installing EnvyNG several times, others modified the xorg.conf. I
> tried the EnvyNG route and it uninstalls the proprietary drivers and
> installs the drivers. Then I either get 640x480 or X won't even start.
> I thought maybe this was a problem specific to the MX400 so I tried
> installing using a Geforce FX5200 and I'm getting the same problem. I
> have to admit this is very frustrating as I've always been able to
> just install and it works. But this time for the life of me I just
> can't get it work on this machine. I messed with this for the last
> couple of days and I've gone no where. I can't believe that US 8.04
> won't work on this hardware.
> I've noticed several times that the machine will stop on Timidity and
> just hang when I try to reboot. Not sure if that has anything to do
> with it or not.
> Any help I can get will be greatly appreciated. I would really like to
> get this machine back up and running.
- From the command line, try:
dpkg-reconfigure xserver-xorg

Choose the nv driver (open source 2d only).  This should get you back
into graphical mode.  If you do not need 3D (and I mean need, as in it
is *required* to get your work done, not because you think compiz is
purdy) I would stick with the 2d drivers.  I have had problems in the
past with the proprietary video drivers and real time kernels.

When choosing drivers, I believe there is a legacy nVidia driver, which
is the one you want.  You could also download the latest (legacy) driver
directly from nvidia, and install it via the CLI.

Version: GnuPG v1.4.6 (GNU/Linux)
Comment: Using GnuPG with Mozilla -


More information about the Ubuntu-Studio-users mailing list