release file not found

Fran López budindefran at
Sun Jul 8 07:16:23 BST 2007

Hello there, may someone can help me.

I've downloaded the iso file for Ubuntu Studio, made the cd, botted it
and installed OK on my computer.
Then, I took the disk to another computer, booted it and got only to
the CD checking step of installation. There, I get an error message
that tells me that no "Release" file can be found.

I thought maybe the CD got damaged, but i booted it on another
computer and it worked just fine.
Downloaded the ISO file again, burnt another CD and the same thing
happened. It worked fine on two other computers, but on the one i
wanted to install Ubuntu Studio, I got only to step 2 or 3 of
installation (cd check) and got that error message ("no release file

Actually, i got exactly the same problem trying to install 64 studio,
so i thought maybe it was some kind of bug with the Debian installer.

Doing some research on the internet, i found this
I'll copy the relevant part here:

----------START COPY----------
New bug:
The cdrom-detect script does not adequately check that it has found
the Release file.
Please could someone clone this bug to the appropriate package,and add
a "patch" tag?

The problem is this:
/var/lib/dpkg/info/cdrom-detect.postinst sets "suite" using this code:

for distlink in stable testing unstable ; do
if [ -e $relfile ] ; then
suite=$(sed -n 's/^Suite: *//p' $relfile)
log "Detected CD with '$suite' distribution"
db_set mirror/suite $suite


But it never checks that the value of "suite" is correct, ie that
the "[ -e $relfile ]" test condition was ever true.

This causes the cdrom-detect program to exit with an incorrect status
(ok, when in fact detection failed at some level) and a subsequent failure
in cdrom-retriever.

I propose these lines be appended below the "done" statement:
-------------------------------- snip ------------------------------------
if [ "X" = "X${suite}" ]; then
fail "Could not determine the package 'suite'. Is the cdrom OK?"
if [ ! -e "/cdrom/dists/$suite/Release" ]; then
fail "No such file '/cdrom/dists/$suite/Release'. Is the cdrom OK?"
-------------------------------- snip ------------------------------------
--------------END COPY--------------

As far as I can understand (and there's a huge chance i'm getting this
wrong), there's a bug with the install script and this guy is posting
a patch solution.
But I don't really know how to do that.

Has anyone experienced the same problem?
Is there a solution?
I have to build my own patch? If so, would anyone be kind enough to
guide me step by setp to do so?

-Fran Lopez

More information about the Ubuntu-Studio-users mailing list