[ubuntu-studio-devel] Solution to my problem

Mike Squires michael.leslie.squires at gmail.com
Wed Jul 17 19:25:14 UTC 2019

I've had problems using Ubuntu Studio 19.04 on my Supermicro X7DAE dual 
quad core Xeon machine due to speed problems, primarily disk speed.

Disk-to-disk copies clock at a max of 3MB/sec using hdparm; 16.04 clocks 
more than 30Mb/sec.

I have found what may be a solution, but I don't know why it seems to work.

I went back to 18.04 and installed, installed the PPA for backports, and 
updated; resulting system ran slightly better than my experience with 
19.04, but not usable.

As an experiment I reinstalled 18.04 and then updated only the standard 
Ubuntu parts, installed the backports PPA, and updated; the resulting 
system is running at about the same speed as 16.04 on the same 
hardware.  So far everything I use runs OK at the expected speed.

I have no explanation for this, but am happy to have what looks like a 
way of running a supported version for some time.

I did notice the following things about "grub":

If there is only a 18.04 Studio partition on the disk "grub" does not 
seem to be automatically installed, and the grub menu does not appear.  
I tried this twice with two different DVDs, same result.

When "grub" is installing it finds two LINUX kernels to boot but both 
are labeled as "low latency" when being installed by "grub". Is the 
second one really a version without the "low latency" mods?

I tried excluding the Spectre related patches using the "pti=off" option 
which improved 19.04 by about 10 to 20% (3MB/sec to 3.3 or 3.6 MB/sec) 
so that isn't my problem.

Michael L. Squires, Ph.D., M.P.A.
546 North Park Ridge Road
Bloomington, IN 47408
Home phone: 812-333-6564
Cell phone: 812-369-5232
www.siralan.org or www.smithgreensound.com
UN*X at home since 1985

More information about the ubuntu-studio-devel mailing list