pulse jack testing

Len Ovens len at ovenwerks.net
Sun Nov 4 16:13:08 UTC 2012


On Sun, November 4, 2012 4:36 am, ttoine wrote:
> Len, I I don't have the "jack fails" problem (step 7), jack starts well.
> Then, I have to select the Jack Sink for Pulse Audio "sound card". But I
> use a firewire sound card with jack, not the integrated Intel HD chipset.
>
> Are you using only one sound card ?  Are you using the dbus option ? do
> you
> use the pulseaudio-module-jack package or do you use a custom script ?

Ya it would work ok that way. The problem is when using the same card for
both PA use without jack and with jack. In 12.04, I could have audasious
playing a file in pulse to hw:1 and start jackdbus with qjackctl to take
hw:1 and the stream to hw:1 would stop when jackdbus took it. I could then
use pavucontrol to switch the stream to jack-sink and the stream would
continue from where it stopped, but through jackdbus. It worked very well.

Now if I try that:
-the stream does stop
-jackdbus errors out saying it can't get the device
-trying to start jack a second time releases PA and the stream starts
   playing again
-jack still doesn't start
-the only way to get jack to work again is to restart both jack and PA


-- 
Len Ovens
www.OvenWerks.net




More information about the Ubuntu-Studio-devel mailing list