Ubuntu Studio 8.10, -rt and 2.6.27

Cory K. coryisatm at ubuntu.com
Mon Sep 1 22:28:34 BST 2008


hollunder at gmx.at wrote:
> Wouldn't the out-of-sync kernel also mean security issues?
>   

Yes.

> I'm pretty sure that quite some people use ubuntu studio as general
> purpose system as well, so that would be an issue.
>   

While we don't necessarily create Studio with this in mind, we know most
do. :)

> How about: shipping -generic until there is a .27-rt and
> provide the out-of-sync kernel as option in a ppa.
> It would be great if the .27-rt would be able to automagically replace
> the ppa version.
>   

This is an idea yes. But, a user would have to manually add the PPA
after their upgrade to Intrepid. The Hardy->Intrepid upgrade would
require a little more manual intervention than normal. And no matter how
well the instructions were, people will complain.

This is all certainly doable, we're just gonna get alot of crap. Sux
when we're all volunteers.

> I haven't tested those kernels yet, and while it is said that more and
> more rt-stuff goes into the generic kernel word is out that .26 is
> pretty bad for audio and midi.
>   

Yep. As stated by Paul D. on another list.

> It would be good to hear some hands-on experience from people who
> already test intrepid.
>   

Agreed.

-Cory K.




More information about the Ubuntu-Studio-devel mailing list