[orca-list] Orca Fails in Studio, Espeak Settings Not Applied in Feisty, Audio Woes

Henrik Nilsen Omma henrik at ubuntu.com
Mon May 21 15:49:27 BST 2007


I'm copying the Ubuntu Studio development mailing list to make them 
aware of this. It seems they have chosen to use the alternate installer, 
presumably because ubiquity does not suit their needs (?) We would hope 
that all our derivatives choose to keep the accessibility infrastructure 
in place so that the variety of options will be available to everyone.

It seems there are several metapackages you can install from the stock 
ubuntu to get the studio functionality, such as ubuntustudio-audio. That 
can serve as a solution in the short term at least. type 'apt-get 
install ubuntustudio-audio ubuntustudio-audio-plugins' at a command line 
or use synaptic.

The Ubuntu Studio theme is actually quite high contrast (and inverse) so 
with bigger fonts it might be quite usable.


Veli-Pekka Tätilä wrote:
> Hi,
> I asked about Ubuntu Studio and Orca a while back. Well, now I've tried it 
> out and the results sure look bad. Ubuntu Studio does have the accessibility 
> boot menu and the screen reader option in it. There are also separate 
> options for text based and graphical installers. However, when I choose the 
> graphical installer and Orca, keyboard and language selection as well as 
> hardware detection happen in ASCII graphics in full-screen, meaning Orca 
> sure cannot read those. I asked for sighted help but the install didn't 
> complete that way either. It complained about not being able to mount the 
> cD, even though the installation medium is a DVD. So I really cannot 
> recommend Ubuntu Studio yet and am unsure if Orca will work in it. Too bad I 
> learned Rose Garden is QT3 only, so no accessible MIDI seq I guess. A MIDI 
> sequencer is one of the apps I absolutely need, if I'm going to make any 
> music in LInux, using the hardware I already have, too bad.
> Then I tried a normal Ubuntu 7.04 system with the accessibility options. It 
> speaks using eSpeak fine in my laptop machine which is an HP NX8220 with a 
> SoundMax Digital Audio card. HOwever, the speech rate and voice selection 
> controls had no effect initially even if hitting OK or apply. Only after I 
> had quitted Orca and ran it again, did it apply the new Espeak settings. I 
> suppose this is a known problem in the version of orca that comes with 
> Ubuntu 7.04. But thought I'd mention it, just in case, if it might be 
> particular to my machine. The Ubuntu Accessibility WIki does not mention the 
> issue at all.
> Also, is there anything one can do if the speech fails to run, I.e. is there 
> an accessible way to find out which sound card Gnome has found? I have a 
> TerraTec EWS88MT card on my desktop machine, its the ICE24 chipset I think, 
> and it does not speak in Ubuntu 7.04 and Orca. I seem to vaguely recall it 
> used to speak in Ubuntu 6.10, so there might be hope. I know the TerraTec 
> has ALSA drivers so when eSpeak speaks does it use PortAudio via ALSA?
> I've tested both the TerraTec system wave out and the wave out 1/2 but 
> neither plays system sounds nor the speech. But it might be that Linux has 
> chosen some other out device in stead, such as the SP/DIF or wave 7/8. But 
> how can I tell without trying them all? Sometimes I've also had issues with 
> the volume on some cards. So how do I adjust the volume of individual outs 
> using the Gnome volume control? As I cannot read the text, I would need the 
> name of the volume control app so I can run it using the run box.
> Another accessibility option I would appreciate would be both speech and 
> magnification and also Braille at bootup. I have a bit of sight left, and am 
> using all 3 in WIndows, with Dolphin SUpernova.
> Any help appreciated. I hope this post is not classified as OT, as it is 
> somewhat Ubuntu rrelated. But hey, Gnome and Orca Should work the same 
> regardless of distro. I suppose I should also try the Ubuntu Accessibility 
> list, too.

More information about the Ubuntu-Studio-devel mailing list