[Bug 1338482] Re: Synaptic backend doesn't work in apturl

Vlad Orlov 1338482 at bugs.launchpad.net
Sat Aug 25 12:30:06 UTC 2018


This is the updated debdiff which adds switch from gksu to pkexec to
make Synaptic actually run.

** Attachment added: "Debdiff with the fix for Bionic (with pkexec instead of gksu)"
   https://bugs.launchpad.net/ubuntu/+source/apturl/+bug/1338482/+attachment/5180647/+files/apturl-debdiff-bionic-with-pkexec

** Patch removed: "Debdiff with the fix for Bionic (updated 21.04.2018)"
   https://bugs.launchpad.net/ubuntu/+source/apturl/+bug/1338482/+attachment/5124831/+files/apturl-debdiff-bionic

-- 
You received this bug notification because you are a member of Ubuntu
Sponsors Team, which is subscribed to the bug report.
https://bugs.launchpad.net/bugs/1338482

Title:
  Synaptic backend doesn't work in apturl

Status in apturl package in Ubuntu:
  Fix Released
Status in apturl source package in Trusty:
  Fix Committed
Status in apturl source package in Xenial:
  Fix Committed
Status in apturl source package in Bionic:
  Fix Committed

Bug description:
  [Impact]

  The Synaptic backend in apturl is non-functional. Trying to use it makes
  apturl crash with Python error message.

  The fix for this issue is provided in the debdiffs attached to the
  report.

  It's a long-standing bug which is present in all current Ubuntu releases,
  starting from Trusty. Would be nice to get it finally fixed. A non-working
  backend isn't good at all, especially when the only other backend (aptdaemon)
  might be removed soon, as stated in bug 1673258.

  [Test Case]

  The easiest way to make apturl use the Synaptic backend (without removing
  aptdaemon from the system) is to set the environment variable when launching
  it from the terminal:

  $ UPDATE_MANAGER_FORCE_BACKEND_SYNAPTIC=1 apturl apt://gnome-
  calculator

  You can use any other package which isn't installed. I chose gnome-calculator
  as it wasn't installed in my Xubuntu and Ubuntu MATE systems.

  The result of this will be crash of apturl with Python error message.
  The package won't be installed.

  [Regression Potential]

  The patch only affects the Synaptic backend. It doesn't affect aptdaemon
  backend or any other parts of code. Since the Synaptic backend was broken
  before, it's not possible to break it further with some regression.

  [Original Description]

  System: Xubuntu 14.10
  apturl version: 0.5.2ubuntu4

  If you'll tell apturl to use the Synaptic backend (by either removing
  aptdaemon from the system or specifying
  UPDATE_MANAGER_FORCE_BACKEND_SYNAPTIC=1 before apturl in the
  terminal), it crashes with this error:

  $ UPDATE_MANAGER_FORCE_BACKEND_SYNAPTIC=1 apturl apt://gcalctool
  /usr/lib/python3/dist-packages/AptUrl/gtk/GtkUI.py:4: PyGIDeprecationWarning: Since version 3.11, calling threads_init is no longer needed. See: https://wiki.gnome.org/PyGObject/Threading
    GObject.threads_init()
  Traceback (most recent call last):
    File "/usr/bin/apturl-gtk", line 43, in <module>
      ui = GtkUI()
    File "/usr/lib/python3/dist-packages/AptUrl/gtk/GtkUI.py", line 38, in __init__
      self.backend = get_backend(self.dia)
    File "/usr/lib/python3/dist-packages/AptUrl/gtk/backend/__init__.py", line 49, in get_backend
      return InstallBackendSynaptic(*args, **kwargs)
  TypeError: __init__() missing 1 required positional argument: 'action'

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/apturl/+bug/1338482/+subscriptions



More information about the Ubuntu-sponsors mailing list