[Bug 1752411] Re: bind9-host, avahi-daemon-check-dns.sh hang forever causes network connections to get stuck

Robie Basak 1752411 at bugs.launchpad.net
Fri Aug 3 13:06:57 UTC 2018

Thank you for working on this. I agree with your approach. The debdiff
looks good.

I think that though it's clear that the bug is in the host command,
given that we haven't been able to figure out the fix (I spent some time
on it too), it's reasonable to add the timeout command as in your patch
as a workaround. No need for the problem to persist when the workaround
is so clean and clear. I also approve the timeout workaround for SRU in
principle. We can leave a bug task open for bind, but consider a
separate bug task resolved in avahi packaging once this workaround is

A couple of comments from your current debdiff:

Please leave a comment above the timeout line explaining why it is there
("Workaround for LP: #1752411" is sufficient). For the SRU, I would
prefer a version string of "0.7-3.1ubuntu1.1" ("0.7-3.1ubuntu2" is
technically OK but doesn't convey that it is an SRU so well).

Please could you prepare a debdiff for Cosmic so that we can fix it
there first? Then follow
https://wiki.ubuntu.com/StableReleaseUpdates#Procedure and attach an
updated debdiff for the SRU to Bionic. I'll be happy to sponsor both,
but will then need review from another SRU team member to accept it from
the queue.

You received this bug notification because you are a member of Ubuntu
Sponsors Team, which is subscribed to the bug report.

  bind9-host, avahi-daemon-check-dns.sh hang forever causes network
  connections to get stuck

Status in avahi package in Ubuntu:
Status in bind9 package in Ubuntu:
Status in openconnect package in Ubuntu:
Status in avahi package in Debian:

Bug description:
  On 18.04 Openconnect connects successfully to any of multiple VPN
  concentrators but network traffic does not flow across the VPN tunnel
  connection. When testing on 16.04 this works flawlessly. This also
  worked on this system when it was on 17.10.

  I have tried reducing the mtu of the tun0 network device but this has
  not resulted in me being able to successfully ping the IP address.

  Example showing ping attempt to the IP of DNS server:

  ~$ cat /etc/resolv.conf 
  # Dynamic resolv.conf(5) file for glibc resolver(3) generated by resolvconf(8)
  # is the systemd-resolved stub resolver.
  # run "systemd-resolve --status" to see details about the actual nameservers.


  liam at liam-lat:~$ netstat -nr
  Kernel IP routing table
  Destination     Gateway         Genmask         Flags   MSS Window  irtt Iface         UG        0 0          0 wlp2s0 UGH       0 0          0 wlp2s0     U         0 0          0 docker0     U         0 0          0 docker0     U         0 0          0 tun0 UH        0 0          0 tun0   U         0 0          0 wlp2s0
  liam at liam-lat:~$ ping
  PING ( 56(84) bytes of data.
  --- ping statistics ---
  4 packets transmitted, 0 received, 100% packet loss, time 3054ms

  ProblemType: Bug
  DistroRelease: Ubuntu 18.04
  Package: openconnect 7.08-3
  ProcVersionSignature: Ubuntu 4.15.0-10.11-generic 4.15.3
  Uname: Linux 4.15.0-10-generic x86_64
  ApportVersion: 2.20.8-0ubuntu10
  Architecture: amd64
  CurrentDesktop: ubuntu:GNOME
  Date: Wed Feb 28 22:11:33 2018
  InstallationDate: Installed on 2017-06-15 (258 days ago)
  InstallationMedia: Ubuntu 16.04.1 LTS "Xenial Xerus" - Release amd64 (20160719)
  SourcePackage: openconnect
  UpgradeStatus: Upgraded to bionic on 2018-02-22 (6 days ago)

To manage notifications about this bug go to:

More information about the Ubuntu-sponsors mailing list