[Bug 540668] Re: aptitude crashed when upgrading from 10.04 alpha 1

Apport retracing service der.pitti at gmail.com
Thu Apr 8 20:21:44 BST 2010


*** This bug is a duplicate of bug 515525 ***
    https://bugs.launchpad.net/bugs/515525

Thank you for taking the time to report this crash and helping to make
Ubuntu better.  This particular crash has already been reported and is a
duplicate of bug #515525, so is being marked as such.  Please look at
the other bug report to see if there is any missing information that you
can provide, or to see if there is a workaround for the bug.
Additionally, any further discussion regarding the bug should occur in
the other report.  Please continue to report any other bugs you may
find.

** Attachment removed: "CoreDump.gz"
   http://launchpadlibrarian.net/41198872/CoreDump.gz

** Attachment removed: "Dependencies.txt"
   http://launchpadlibrarian.net/41198873/Dependencies.txt

** Attachment removed: "Disassembly.txt"
   http://launchpadlibrarian.net/41198874/Disassembly.txt

** Attachment removed: "ProcMaps.txt"
   http://launchpadlibrarian.net/41198876/ProcMaps.txt

** Attachment removed: "ProcStatus.txt"
   http://launchpadlibrarian.net/41198877/ProcStatus.txt

** Attachment removed: "Registers.txt"
   http://launchpadlibrarian.net/41198878/Registers.txt

** Attachment removed: "Stacktrace.txt"
   http://launchpadlibrarian.net/41198879/Stacktrace.txt

** Attachment removed: "ThreadStacktrace.txt"
   http://launchpadlibrarian.net/41198880/ThreadStacktrace.txt

** This bug has been marked a duplicate of bug 515525
   aptitude assert failure: *** glibc detected *** aptitude: double free or corruption (!prev): 0x08f9d658 ***

** Visibility changed to: Public

** Tags removed: need-i386-retrace

-- 
aptitude crashed when upgrading from 10.04 alpha 1
https://bugs.launchpad.net/bugs/540668
You received this bug notification because you are a member of Ubuntu
Sponsors Team, which is a direct subscriber (via bug 515525).

Status in “aptitude” package in Ubuntu: New

Bug description:
Binary package hint: aptitude

$ lsb_release -rd
Description:	Ubuntu lucid (development branch)
Release:	10.04

$ sudo aptitude safe-upgrade
[... many package installs omitted ...]
Procesando disparadores para libc-bin ...
ldconfig deferred processing now taking place
Procesando disparadores para initramfs-tools ...
update-initramfs: Generating /boot/initrd.img-2.6.32-16-generic
Procesando disparadores para python-support ...
*** glibc detected *** aptitude: double free or corruption (!prev): 0x08ce5088 ***
======= Backtrace: =========
/lib/tls/i686/cmov/libc.so.6(+0x6b611)[0x385611]
/lib/tls/i686/cmov/libc.so.6(+0x6ce68)[0x386e68]
/lib/tls/i686/cmov/libc.so.6(cfree+0x6d)[0x389f2d]
/usr/lib/libstdc++.so.6(_ZdlPv+0x21)[0x90d731]
/usr/lib/libstdc++.so.6(_ZdaPv+0x1d)[0x90d78d]
aptitude[0x81693bf]
aptitude[0x81872dd]
aptitude[0x8183512]
aptitude[0x81492a0]
aptitude[0x8145e05]
aptitude[0x805e4df]
/lib/tls/i686/cmov/libc.so.6(__libc_start_main+0xe6)[0x330bd6]
aptitude[0x805c6a1]
======= Memory map: ========
00110000-001c9000 r-xp 00000000 08:01 136182     /usr/lib/libcwidget.so.3.0.0
001c9000-001ca000 ---p 000b9000 08:01 136182     /usr/lib/libcwidget.so.3.0.0
001ca000-001cd000 r--p 000b9000 08:01 136182     /usr/lib/libcwidget.so.3.0.0
001cd000-001ce000 rw-p 000bc000 08:01 136182     /usr/lib/libcwidget.so.3.0.0
001ce000-00316000 r-xp 00000000 08:01 135393     /usr/lib/libxapian.so.15.6.9
00316000-00319000 r--p 00147000 08:01 135393     /usr/lib/libxapian.so.15.6.9
00319000-0031a000 rw-p 0014a000 08:01 135393     /usr/lib/libxapian.so.15.6.9
0031a000-00467000 r-xp 00000000 08:01 261855     /lib/tls/i686/cmov/libc-2.11.1.so
00467000-00468000 ---p 0014d000 08:01 261855     /lib/tls/i686/cmov/libc-2.11.1.so
00468000-0046a000 r--p 0014d000 08:01 261855     /lib/tls/i686/cmov/libc-2.11.1.so
0046a000-0046b000 rw-p 0014f000 08:01 261855     /lib/tls/i686/cmov/libc-2.11.1.so
0046b000-0046e000 rw-p 00000000 00:00 0 
0046e000-00481000 r-xp 00000000 08:01 261919     /lib/tls/i686/cmov/libnsl-2.11.1.so
00481000-00482000 r--p 00012000 08:01 261919     /lib/tls/i686/cmov/libnsl-2.11.1.so
00482000-00483000 rw-p 00013000 08:01 261919     /lib/tls/i686/cmov/libnsl-2.11.1.so
00483000-00485000 rw-p 00000000 00:00 0 
00485000-0048d000 r-xp 00000000 08:01 261959     /lib/tls/i686/cmov/libnss_nis-2.11.1.so
0048d000-0048e000 r--p 00007000 08:01 261959     /lib/tls/i686/cmov/libnss_nis-2.11.1.so
0048e000-0048f000 rw-p 00008000 08:01 261959     /lib/tls/i686/cmov/libnss_nis-2.11.1.so
0048f000-00490000 r-xp 00000000 08:01 153103     /usr/lib/gconv/ISO8859-1.so
00490000-00491000 r--p 00001000 08:01 153103     /usr/lib/gconv/ISO8859-1.so
00491000-00492000 rw-p 00002000 08:01 153103     /usr/lib/gconv/ISO8859-1.so
004a3000-004c7000 r-xp 00000000 08:01 261915     /lib/tls/i686/cmov/libm-2.11.1.so
004c7000-004c8000 r--p 00023000 08:01 261915     /lib/tls/i686/cmov/libm-2.11.1.so
004c8000-004c9000 rw-p 00024000 08:01 261915     /lib/tls/i686/cmov/libm-2.11.1.so
00586000-00588000 r-xp 00000000 08:01 265805     /lib/tls/i686/cmov/libutil-2.11.1.so
00588000-00589000 r--p 00001000 08:01 265805     /lib/tls/i686/cmov/libutil-2.11.1.so
00589000-0058a000 rw-p 00002000 08:01 265805     /lib/tls/i686/cmov/libutil-2.11.1.so
005e1000-005e6000 r-xp 00000000 08:01 136838     /usr/lib/libsigc-2.0.so.0.0.0
005e6000-005e7000 r--p 00004000 08:01 136838     /usr/lib/libsigc-2.0.so.0.0.0
005e7000-005e8000 rw-p 00005000 08:01 136838     /usr/lib/libsigc-2.0.so.0.0.0
006b5000-006b6000 r-xp 00000000 00:00 0          [vdso]
006e0000-006e6000 r-xp 00000000 08:01 261921     /lib/tls/i686/cmov/libnss_compat-2.11.1.so
006e6000-006e7000 r--p 00006000 08:01 261921     /lib/tls/i686/cmov/libnss_compat-2.11.1.so
006e7000-006e8000 rw-p 00007000 08:01 261921     /lib/tls/i686/cmov/libnss_compat-2.11.1.so
0072c000-0072e000 r-xp 00000000 08:01 261913     /lib/tls/i686/cmov/libdl-2.11.1.so
0072e000-0072f000 r--p 00001000 08:01 261913     /lib/tls/i686/cmov/libdl-2.11.1.so
0072f000-00730000 rw-p 00002000 08:01 261913     /lib/tls/i686/cmov/libdl-2.11.1.so
00826000-00839000 r-xp 00000000 08:01 262002     /lib/libz.so.1.2.3.3
00839000-0083a000 r--p 00012000 08:01 262002     /lib/libz.so.1.2.3.3
0083a000-0083b000 rw-p 00013000 08:01 262002     /lib/libz.so.1.2.3.3
00852000-0093b000 r-xp 00000000 08:01 133557     /usr/lib/libstdc++.so.6.0.13 (deleted)
0093b000-0093f000 r--p 000e9000 08:01 133557     /usr/lib/libstdc++.so.6.0.13 (deleted)
0093f000-00940000 rw-p 000ed000 08:01 133557     /usr/lib/libstdc++.so.6.0.13 (deleted)
00940000-00947000 rw-p 00000000 00:00 0 
0095c000-00978000 r-xp 00000000 08:01 261902     /lib/libgcc_s.so.1 (deleted)
00978000-00979000 r--p 0001b000 08:01 261902     /lib/libgcc_s.so.1 (deleted)
00979000-0097a000 rw-p 0001c000 08:01 261902     /lib/libgcc_s.so.1 (deleted)
009dd000-009f8000 r-xp 00000000 08:01 261678     /lib/ld-2.11.1.so
009f8000-009f9000 r--p 0001a000 08:01 261678     /lib/ld-2.11.1.so
009f9000-009fa000 rw-p 0001b000 08:01 261678     /lib/ld-2.11.1.so
00b13000-00bd8000 r-xp 00000000 08:01 136055     /usr/lib/libapt-pkg-libc6.10-6.so.4.8.0 (deleted)
00bd8000-00bda000 r--p 000c5000 08:01 136055     /usr/lib/libapt-pkg-libc6.10-6.so.4.8.0 (deleted)
00bda000-00bdb000 rw-p 000c7000 08:01 136055     /usr/lib/libapt-pkg-libc6.10-6.so.4.8.0 (deleted)
00d4b000-00d55000 r-xp 00000000 08:01 261931     /lib/tls/i686/cmov/libnss_files-2.11.1.so
00d55000-00d56000 r--p 00009000 08:01 261931     /lib/tls/i686/cmov/libnss_files-2.11.1.so
00d56000-00d57000 rw-p 0000a000 08:01 261931     /lib/tls/i686/cmov/libnss_files-2.11.1.so
00e79000-00e8e000 r-xp 00000000 08:01 261978     /lib/tls/i686/cmov/libpthread-2.11.1.so
00e8e000-00e8f000 r--p 00014000 08:01 261978     /lib/tls/i686/cmov/libpthread-2.11.1.so
00e8f000-00e90000 rw-p 00015000 08:01 261978     /lib/tls/i686/cmov/libpthread-2.11.1.so
00e90000-00e92000 rw-p 00000000 00:00 0 
00ebc000-00f2b000 r-xp 00000000 08:01 136247     /usr/lib/libept.so.0.5.30
00f2b000-00f2c000 r--p 0006f000 08:01 136247     /usr/lib/libept.so.0.5.30
00f2c000-00f2d000 rw-p 00070000 08:01 136247     /usr/lib/libept.so.0.5.30
00f4c000-00f8c000 r-xp 00000000 08:01 272089     /lib/libncursesw.so.5.7
00f8c000-00f8e000 r--p 00040000 08:01 272089     /lib/libncursesw.so.5.7
00f8e000-00f8f000 rw-p 00042000 08:01 272089     /lib/libncursesw.so.5.7
08048000-08251000 r-xp 00000000 08:01 133223     /usr/bin/aptitude
08251000-08252000 r--p 00208000 08:01 133223     /usr/bin/aptitude
08252000-08253000 rw-p 00209000 08:01 133223     /usr/bin/aptitude
08253000-08255000 rw-p 00000000 00:00 0 
089b0000-08d00000 rw-p 00000000 00:00 0          [heap]
b57dd000-b5852000 rw-p 00000000 00:00 0 
b5852000-b5853000 ---p 00000000 00:00 0 
b5853000-b6053000 rw-p 00000000 00:00 0 
b6053000-b6075000 r--p 00000000 08:01 312603     /usr/share/locale-langpack/es/LC_MESSAGES/libc.mo (deleted)
b6239000-b6241000 r--p 00000000 08:01 295020     /usr/share/locale-langpack/es/LC_MESSAGES/libapt-pkg4.8.mo (deleted)
b6241000-b6242000 rw-p 00000000 00:00 0 
b7500000-b7521000 rw-p 00000000 00:00 0 
b7521000-b7600000 ---p 00000000 00:00 0 
b767e000-b767f000 rw-p 00000000 00:00 0 
b767f000-b7686000 r--p 00000000 08:01 310942     /usr/share/locale/es/LC_MESSAGES/libapt-pkg4.8.mo (deleted)
b7686000-b76a8000 r--p 00000000 08:01 312415     /usr/share/locale-langpack/es/LC_MESSAGES/aptitude.mo (deleted)Cancelado (`core' generado)

ProblemType: Crash
Architecture: i386
AssertionMessage: *** glibc detected *** aptitude: double free or corruption (!prev): 0x08ce5088 ***
Date: Thu Mar 18 00:37:01 2010
DistroRelease: Ubuntu 10.04
ExecutablePath: /usr/bin/aptitude
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Alpha i386 (20100224.1)
Package: aptitude 0.4.11.11-1ubuntu9
ProcCmdline: aptitude safe-upgrade
ProcEnviron:
 PATH=(custom, no user)
 LANG=es_CL.utf8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-16.25-generic
Signal: 6
SourcePackage: aptitude
StacktraceTop:
 __kernel_vsyscall ()
 raise () from /lib/tls/i686/cmov/libc.so.6
 abort () from /lib/tls/i686/cmov/libc.so.6
 ?? () from /lib/tls/i686/cmov/libc.so.6
 ?? () from /lib/tls/i686/cmov/libc.so.6
Title: aptitude assert failure: *** glibc detected *** aptitude: double free or corruption (!prev): 0x08ce5088 ***
Uname: Linux 2.6.32-16-generic i686
UserGroups:





More information about the Ubuntu-sponsors mailing list