[Bug 181258] Re: problem about diskless booting

Teej xteejyx at googlemail.com
Mon Apr 5 16:20:07 BST 2010

Sponsors Team subscribed. Patch above.

problem about diskless booting
You received this bug notification because you are a member of Ubuntu
Sponsors Team, which is a direct subscriber.

Status in “initramfs-tools” package in Ubuntu: Triaged

Bug description:
I am trying to install kubuntu 7.10 (not updated, just the distro as it comes from the installation cd) using Diskless booting from a remote system which stores the kernel and the filesystem that will be used on other clients. I followed this howto: 
but when I tried to boot from the client, the process stopped due to some kernel panic issue

ipconfig: eth0: SIOCGIFINDEX: No such device
ipconfig: no devices to configure
/init: .: 1: Can't open /tmp/net-eth0.conf
[  25.445685] Kernel panic - not syncing: Attempted to kill init!

Googling around I found similar problems from other *ubuntu users and it seemed to be a problem related to NetworkManager
I applied the workaround described in the link above

      Note: For Ubuntu 7.04 (Feisty Fawn) it seems the /etc/network/interfaces needs a little tweak, in order *not* to have the NetworkManager fiddle with the interface since it's already configured (see also bug #111227 : "NFS-root support indirectly broken in Feisty")

so, here's what your interfaces file should look like:

# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface, commented out for NFS root
#auto eth0
#iface eth0 inet dhcp
iface eth0 inet manual

but it did not work. than I tried another trick described in http://wiki.ubuntu.org.cn/UbuntuHelp:Installation/OnNFSDriveWithLocalBoot

There is currently a bug in NetworkManager that means even though the machine gets an IP just fine from the kernel booting the network IF goes down and up again. This is bad, we don't want the network to go down while trying to read files over the network! A quick hack is...

vim etc/network/interfaces
Comment out the lines for eth0 (Or whatever your ethernet card is called)

We also need to do this to stop NetworkManager messing with the network card. Bit of a hack...

vim etc/default/NetworkManager
vim etc/default/NetworkManagerDispatcher
Add a line with "exit" to both files


but nothing changed and I got again the same error. I even looked up at bug #111227 : "NFS-root support indirectly broken in Feisty" and Bug #92338 in network-manager (Ubuntu)
I am not an expert; I understood that the problem could be caused by avahi, DHCDBD, NetworkManager and NetworkManagerDispatcherand daemons.
I didn't know how to make the clients not to start avahi and dhcdbd so I tried to disable them by disabling them an the server with sycvconfig and then copying everything on /nfsroot (where the distributed stuff lies); my hope was to copy the files overwritten with sysvconfig in the client configuration stuff.
Then i put an "exit" record in the (created new) files
and added an "exit 0" at the beginning of 

again nothing changed.

Could you please give me some help?
Thanks in advance


More information about the Ubuntu-sponsors mailing list