[Bug 528907] Re: unable to mount disks in dolphin / hal permission denied

Launchpad Bug Tracker 528907 at bugs.launchpad.net
Thu Apr 1 17:53:39 BST 2010

This bug was fixed in the package hal - 0.5.14-0ubuntu5

hal (0.5.14-0ubuntu5) lucid; urgency=low

  * Revert the previous change. We do not want any user to modify internal
    system partitions without any authentication, it creates too much of a
    security hole. Instead, the patch in kdelibs should be fixed, after all it
    worked fine in karmic and earlier. (LP: #528907)
 -- Martin Pitt <martin.pitt at ubuntu.com>   Thu, 01 Apr 2010 12:01:16 +0200

** Changed in: hal (Ubuntu Lucid)
       Status: Fix Committed => Fix Released

unable to mount disks in dolphin / hal permission denied
You received this bug notification because you are a member of Ubuntu
Sponsors Team, which is a direct subscriber.

Status in “hal” package in Ubuntu: Fix Released
Status in “kdebase” package in Ubuntu: Triaged
Status in “hal” source package in Lucid: Fix Released
Status in “kdebase” source package in Lucid: Triaged

Bug description:
Binary package hint: kdebase

When I tried to mount a unmounted partition in dolphin, I get following error message :
org.freedesktop.Hald.device.volume.permissionDenied: Refusing to mount device /dev/sdax for uid=xxxx

ProblemType: Bug
Architecture: amd64
Date: Sat Feb 27 09:47:29 2010
DistroRelease: Ubuntu 10.04
NonfreeKernelModules: nvidia
Package: dolphin 4:4.4.0-0ubuntu2
ProcVersionSignature: Ubuntu 2.6.32-14.20-generic
SourcePackage: kdebase
Uname: Linux 2.6.32-14-generic x86_64

More information about the Ubuntu-sponsors mailing list