Xenial on USB stick install can't detect itself

Mark Constable markc at renta.net
Fri Apr 8 05:33:51 UTC 2016

On 07/04/16 12:54, Seth Arnold wrote:
>> The usb stick with the server iso is fine and the usb keyboard/mouse works
>> okay on this hardware, it's the destination installation on yet another usb
>> stick that is the problem. When I boot onto the installed OS the initrd does
>> not detect the partition UUID and drops me to the initramfs prompt and the
> Ah, I see. It feels unlikely to be your issue, but you may wish to fiddle
> with the switch in your bios that controls between legacy bios, uefi, and
> a combination of the two.. my first install attempt didn't work because I
> used the "both" setting in my bios.

I get the same results on 2 laptops so I don't think it's a BIOS issue and
thanks to your suggestion I have tried some BIOS boot variations but it's
super annoying to have to waste time doing this when 15.10 works fine.

Last night I tried again by loading a daily ISO on the same kind of brand new
USB stick as the destination and put both into the HP microserver and did the
install on that device. This time the partition was found and it booted okay
BUT now the ethernet interface is missing (tg3.ko) so even though I now have
USB keyboard access I still can't upgrade the packages.

Maybe this is just my bad luck trying beta/dailys that just happen to still
have bugs in the installer that just happen to affect my current needs. I have
been running xenial on my main work laptop for 4 months now and a few weeks ago
I was even so bold as to upgrade my main DELL online server from wily to xenial
and that seems to be working fine. I think I had good reason to feel confident
enough to start installing late term xenial iso's a few weeks before the final
release. However, yesterday I ordered a new DELL server and the techs were good
enough to install the last xenial beta2 and the SSD drives had a hdparm test of
118 Mb/s which is slower than the 200 Mb/s on my other server with a SATA drive!
That tech is now in a world of pain because reinstalling the beta iso has lost
usb keyboard access to the DELL chasis (he is onsite rather than using DRAC).

These are my problems because I am using a pre-release, I understand that, but
as I mentioned I had (false) confidence after using xenial on a couple of key
computers and on DOZENs of VPSs in the last 2 months (on older centos kernels)
that "it's time" to go all in and start installing to more serious hardware.

Frankly, my confidence in ubuntu server is shattered and I'm not sure these
fundamental installation issues will be fixed in the next ~2 weeks.

More information about the ubuntu-server mailing list