Xenial on USB stick install can't detect itself

Mark Constable markc at renta.net
Wed Apr 6 12:28:51 UTC 2016

I just installed a recent daily xenial 64bit server onto a USB stick
that is to go into the internal USB slot of a HP microserver. It used
to work fine with wily and even a manually upgraded wily -> xenial up
till a month ago. This is the 2nd USB stick I've tried and booting up
just gets to the initramfs prompt after 30 seconds of...

Begin: Running /scripts/local-block ... done.

then it says can't find the UUID of the partition I just booted from. On
that HP microserver I have no USB keyboard access so I can't investigate
it any further but when I boot the same USB stick on my laptop I get the
same result and sure enough there is no typical /dev/sdb* devices and
blkid does not show the device I just booted from!

It's like the install did not add any USB drivers or modules to the initrd
image orkernel.

Is this expected behavior with xenial server installs and if so how can
I work around this and force USB modules to be installed to initrd?

More information about the ubuntu-server mailing list