updating cobbler

Timo Aaltonen tjaalton at ubuntu.com
Wed Aug 21 07:13:34 UTC 2013


On 21.08.2013 10:11, Dave Walker wrote:
> On 21 August 2013 07:36, Timo Aaltonen <tjaalton at ubuntu.com> wrote:
>>
>>         Hi
>>
>>   Looks like cobbler has been bitrotting for a while, but I need it on
>> my network so took the packaging and pushed it to alioth:
>>
>> git://git.debian.org/git/collab-maint/cobbler.git debian-unstable
>>
>> It's rebased on 2.4.0, which has changed quite a bit. One thing that
>> doesn't work atm is cobbler-ubuntu-import because of the new 'distro
>> signatures' stuff upstream, not sure how much effort that would need to
>> get going again..
>>
>> I'd like to push this to saucy before FF, because for instance
>> cobbler-web doesn't work at all since precise (#1076290). Any concerns?
>>
>>
>> ps. if testing, SECRET_KEY needs to be set to something sane in
>> settings.py or the web frontend won't load. RPM build hacks this in
>> postinst, probably need to do the same for dpkg too..
>>
>> --
>> t
>>
>> --
>> ubuntu-server mailing list
>> ubuntu-server at lists.ubuntu.com
>> https://lists.ubuntu.com/mailman/listinfo/ubuntu-server
>> More info: https://wiki.ubuntu.com/ServerTeam
>>
> 
> Hi Timo,
> 
> This looks like some great work!
> 
> Are you looking to upload this to Debian in the short term, where we
> can think sync it - or are you seeking sponsorship directly from
> alioth git?

I can't upload to Debian without someone first sponsoring it there (I'm
a DM but can't upload NEW), but can upload directly to Ubuntu.

I think the package still needs some cleanups to be more 'pristine' for
Debian, although some ubuntuisms have been dropped already. Need to file
an ITP bug too.

-- 
t




More information about the ubuntu-server mailing list