kvm-spice no video in 12.04

James Crow james at ultratans.com
Wed Apr 18 20:44:06 UTC 2012


On 04/18/2012 11:18 AM, James Crow wrote:
> Hello,
>
> I posted on the Ubuntu-User list, but received no helpful replies.
>
> I have a 12.04 amd64 desktop install that I am trying to use kvm-spice 
> to run a virtual Windows install. kvm is working fine and I have a 
> regular vnc guest (Windows XP) that is running. I tried to create a 
> new guest using kvm-spice as the hypervisor. I used an iso image and 
> allocated a 40GB image file. Once the image was created, the guest 
> shows as running, but I have no video in either the Virtual Machine 
> Manager or connecting with spicy.
>
> Does anyone have a working kvm-spice install on 12.04?
>
> Thank you,
> James Crow
>
As a follow up, I have recreated the problem on 12.04 server. I have a 
10.04 guest that I cloned. The clone was reconfigured to use qxl and 
spice. In virt manager, there is no way to change the hypervisor from 
kvm to kvm-spice. Using virsh I changed the hypervisor to kvm-spice and 
started the guest.

As another test I left the hypervisor as kvm-spice and changed the video 
back to vnc/cirrus. I was able to start the guest and view the console 
without problem.

Testing other combinations, I found that video on cirrus and Display on 
spice allowed me to connect to the guest with spicec.

It would appear that the problem is with the qxl backend rather than 
kvm-spice. I now need to figure out how to get more logging out of kvm 
with the qxl video device.

Thank you,
James Crow





More information about the ubuntu-server mailing list