troubles copying qcow2 VM images

Serge E. Hallyn serge.hallyn at
Mon Mar 14 21:54:55 UTC 2011

Quoting jurgen.depicker at (jurgen.depicker at
> When trying to start the VM on VLET3, the VM hangs immediately at boot, 
> with following messags in /var/log/messages:
> Mar 14 21:21:30 VLET3 kernel: [255777.604342] type=1400 
> audit(1300134090.205:39): apparmor="STATUS" operation="profile_load" 
> name="libvirt-02f97acb-d586-4eb9-9f59-e1df7a3cd647" pid=29124 
> comm="apparmor_parser"
> Mar 14 21:21:30 VLET3 libvirtd: 21:21:30.803: warning : 
> qemudParsePCIDeviceStrs:1422 : Unexpected exit status '1', qemu probably 


> > Can you sha1sum {/mnt/nfs,/srv/VMs/}/VM1.qcow2?  My guess is this is an
> > NFS bug with large file xfer corruption.
> > 
> > -serge
> Great, I didn't think of that one before!  I thought that was it, but, 
> unfortunately, I ran sha1sum on VLET1 and VLET3's copies, and both give 
> the same checksum.
> I really really don't understand this...  Is there some 'magic' associated 
> with qcow2 images, so you need to copy them in a special way?  But since 
> the sha1sums are identical...
> The funny thing is, most of these images were VMWare images which I 
> converted.  They were first stored on other systems, and I could copy the 
> qcow2 images to VLET1 and they all worked fine.  But now it seems 
> impossible to move them...

A-ha - Did you update the apparmor profile for that libvirt
instance so that it can access the file in the new location?

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 490 bytes
Desc: Digital signature
URL: <>

More information about the ubuntu-server mailing list