Xen 4.1 doesn't support HVM domUs

Stefan Bader stefan.bader at canonical.com
Tue Jul 19 12:59:58 UTC 2011

On 19.07.2011 14:28, Serge E. Hallyn wrote:
> Oops, chuck is out this week.  Adding the whole ubuntu-server
> list.  Thanks for collecting all that info, Boris.
> -serge
> Quoting Boris Derzhavets (bderzhavets at yahoo.com):
>> I  have tested  Chuck's source and rebuilt it one more time.
>> Nothing is there . I mean patches for HVM support.
>> Boris.
>> --- On Tue, 7/19/11, Serge E. Hallyn <serge.hallyn at canonical.com> wrote:
>> From: Serge E. Hallyn <serge.hallyn at canonical.com>
>> Subject: Re: Xen 4.1 doesn't support HVM domUs
>> To: "Boris Derzhavets" <bderzhavets at yahoo.com>
>> Cc: "Serge Hallyn" <serge.hallyn at ubuntu.com>, zulcss at ubuntu.com
>> Date: Tuesday, July 19, 2011, 7:54 AM
>> Quoting Boris Derzhavets (bderzhavets at yahoo.com):
>>> Serge,
>>> I have enough info captured on the Net,  having actually same content as
>>> bug :-
>>> https://bugs.launchpad.net/ubuntu/+source/xen/+bug/811951
>>> Yours  choice of 4.1 Hypervisor appears to be , unfortunately,  very bad
>>> luck.   If you don't like spice , it's up to you.
>>> But Xen Host not supporting HVM domUs  , having broken VFB ( for PV
>>> DomuS)  that's  really bad.
>>> Believe me,  F16 will have either 4.2 stable or 4.1 properly patched.
>>> 4.2 Unstable supports HVM.
>>> The question is : which set of CS's is responsible for this fix  to be
>>> placed in debian/patches.
>> It may be Chuck (cc:d) or else he'd know.
>>> Sorry, to write you that,  you didn't track  Xen development during
>>> several years.  Finally,  Windows 7.5 might be assembled
>>> and named Ubuntu Oneiric.
>> thanks,
>> -serge
Played around with it a bit. So far (and dunno whether Chuck actually is already
on it or aware) I am at:

- need to get a few more modules loaded. At least xen_gntdev and probably
  xen_gntalloc and xen_wdt...
- qemu-keymaps puts itself into /usr/share/qemu-linaro... They are search
  in /usr/share/qemu (of course)
- Having only used older centos based dom0 mostly before, I just tried to
  start the hvm instance with xm create. However there is a xl and xl
  create behaves differently and gets further...
- Using xl create -c, there is stuff searched or tried to create in
  /var/lib/xen, but we only got either /var/lib/xend and /var/lib/xenstored.
- Creating /var/lib/xen gets me a bit further. Though not really the happy
  place I'd liked to be...


More information about the ubuntu-server mailing list