problem in mounting an nfs export on a USB disk

Tapas Mishra mightydreams at
Thu Jan 6 05:05:25 UTC 2011

On Wed, Jan 5, 2011 at 10:03 PM, Serge Hallyn
<serge.hallyn at> wrote:
> Quoting Tapas Mishra (mightydreams at
>> the entries which after your msg I noticed in /var/log/syslog are
>> Jan  5 14:12:14 tapas mountd[1577]: refused mount request from
>> for /media/vol2 (/media/vol2): unmatched host
>> Jan  5 14:13:16 tapas mountd[1577]: refused mount request from
>> for /media/vol2 (/media/vol2): unmatched host
> That seems to confirm that an entry like
>        /media/vol2
> in /etc/exports should work.  Please try that (of course making sure
> to restart with 'exportfs -ra' after making the change on the server).
> thanks,
> -serge

Ok I changed * by IP as you said and it did worked.
I was able to mount the said nfs share on client machine lets say its
hostname is client_hostname
but I was not able to go inside the mounted folder.

On the client machine

mount -t nfs <IP of server>:/media/vol2 /mnt/nfs

this did worked

but when from client machine I do
cd /mnt/nfs I get permission denied.

When I see a ls -l then I see an owner different than root (infact
username:groupname) shows me client machines hostname

here is out put of said nfs mount on client machine

drwx------  1 client_hostname client_hostname 20480 2011-01-03 17:43 nfs

on the nfs server which is my laptop the directory which I exported
its permissions are

drwx------ 1 tapas tapas 20480 2011-01-03 17:43 vol2

So thinking that this might be the problem I tried to change the
permissions on nfs-server folder itself

How ever this attempt to change permissions (as root) on the nfs-server failed.


More information about the ubuntu-server mailing list