11.04->11.10 KVM guest console problem

Serge Hallyn serge.hallyn at canonical.com
Fri Dec 9 21:05:28 UTC 2011


Quoting James Crow (james at ultratans.com):
> On Thu, 08 Dec 2011 21:36:49 -0600, Serge Hallyn
> <serge.hallyn at canonical.com> wrote:
> > On 12/08/2011 11:17 AM, James Crow wrote:
> >> Hi all,
> >>
> >> I am learning my way around with KVM. I have a Dell PowerEdge R410
> server
> >> that I installed 11.04 amd64 on. I then created two guests and
> installed
> >> 10.04.3 amd64 on each. Everything was working up to this point.
> >>
> >> Today, I decided to try the upgrade to 11.10 for the host OS. I did a
> >> virsh save<guest-name>  <save-file>  for each guest and then upgraded
> the
> >> host OS.
> >>
> >> The upgrade seemed to progress without incident. I let the host restart
> >> during the upgrade and once it was done I was able to SSH back in to
> the
> >> host.
> >>
> >> I should note that my home directory on the host is encrypted and I
> have
> >> setup SSH with keys so I can login to the host from my desktop without
> >> entering a password. When I login this way my home directory on the
> host
> >> does not get mounted.
> >>
> >> After the upgrade I connected from my desktop with the GUI virtual
> >> machine
> >> manager and saw that both of my guests were running. Great!, I thought.
> >> The
> >> problem is I am now unable to connect to the console for either guest.
> >> If I
> >> try to open the console from the GUI app the window display "Connecting
> >> to
> >> graphical console for guest." I have waited over an hour and the
> message
> >> stays the same. I am also unable to connect to the guest from within
> >> virsh
> >> through a SSH session.
> > 
> > By 'console' do you mean the serial console, or vnc?  Are you able to 
> > ssh into the guests?  Do they respond to a ping?
> > 
> >> libvirt appears to be working because I can run virsh from SSH and
> >> connect
> >> with the GUI manager. I am able to suspend/save/start the guest. I am
> >> simply unable to view their consoles.
> >>
> >> Any ideas appreciated.
> > 
> > (Below is assuming that the VMs are not running right,  you can't ping 
> > them.  If you can ping them, then likely libvirt is just not hooking up 
> > the serial console right)
> > 
> > If I had to guess, I'd say that by saving and restoring - rather than 
> > shutting down and later restarting - the guests, you ran into an 
> > incompatibility in the save/restore image across qemu versions.  That's 
> > just a guess, though.
> > 
> > So long as you still have the <save-file> for each guest, you could try 
> > starting the guest up clean ('virsh start guest-name') and see if that 
> > comes up fine.
> > 
> > Another thing you could try would be to create a 10.04 chroot (using 
> > debootstrap) on your host, chroot into it, install qemu-kvm and libvirt,
> > copy over the guest config files, and see if you can connect to the 
> > consoles from there.
> > 
> > I'm tempted to ask for guest .xml files, but at that point we'd be 
> > better off talking in a launchpad bug.
> > 
> > -serge
> 
> Serge,
> 
> Thanks for your response.
> 
> This morning I tried again with the gui Virtual Machine Manager and I was
> able to connect to the console (I think the VMM software uses vnc) of one
> of the guests. Yesterday I was able to ssh to and ping this guest so I knew
> it was up. I was simply unable to view the graphical console.
> 
> I moved on to some other tasks and then came back and tried to reconnect.
> This time when attempting to connect to the console (using the VMM gui) the
> "Connecting to graphical console for guest" message simply stayed in place
> of the console. After ~5 minutes of waiting I restarted libvirt-bin on the
> host. After a libvirt-bin restart I was able to connect and view the
> graphical console. After the first connection, I am unable to view the
> console again until I restart libvirt-bin.

Yikes, that definately sounds like a bug.

> It is possible for me to view the graphical console. I just need to
> restart libvirt every other time. There may be some sort of timeout that I
> am not waiting for. I raise this as a possibility because I was able to
> connect first thing this morning after letting the system idle overnight. I
> think this may be a bug in libvirt-bin, but I am unsure of how to get the
> information required for a good bug report.

If you can run remote x on the server just fine, then you can just do

	ubuntu-bug libvirt-bin

There.  But if that fails due to missing browser, then you can do

	apport-cli -f -p libvirt-bin

on the server.  Watch the last line of output for the /var/crash/YYY file it
created.  Copy that file to a machine where you have firefox.  Then on that
machine, run

	ubuntu-bug YYY

where YYY is that filename.  It should file a bug with the information
collected from the server.

thanks,
-serge




More information about the ubuntu-server mailing list