VPN help suggestions

Eric Peters eric at linuxsystems.net
Fri Jun 25 22:39:29 UTC 2010

Hey all,

    I thought I would never ask for help on here, it's more the other way
around I'm the one helping out. Anyway here is what I have run into. I'm
trying to get a simple VPN connection up and authenticate to
a separate  Radius server. Being that most of the clients are going to
Winblows and to make it easy for the users to setup, my thought was to use
PPTPD (poptop) with Radius. I spent a solid 8 hours trying to get PPTPD to
authenticate to the Radius server but PPTPD isn't sending anything to the
Radius server it works great with chap-secrets though. The Radius server is
not the issue because it works great and is authenticating via LDAPS and I
can authenticate on the same server I'm setting up the PPTPD server on via
PAM. For example:

Adding the bellow line to /etc/pam.d/sshd
auth            sufficient      pam_radius_auth.so debug

I can ssh in and authenticate via Radius, my Radius logs show the connection
and everything is happy. But on the same server PPTPD won't have anything to
do with it. Now have also tried this on separate servers as well; with them
running Ubuntu 9.4 to 10.4 with the same result, no packets are being sent
to the Radius server. I have posted this to the POPTOP mail list and Ubuntu
forums but all has been quiet.

So I trashed that Idea because I spent too much time on it, and there is
always another way to skin a cat. So I started down the OpenVPN route and
use the PAM plugin they provide since I know my PAM and Radius are happy
together. I got a test server up authenticating via certs. "Great!!!" Time
to get it authenticating with the openvpn-pam plugin. Well not so fast: When
I enable the PAM plugin in the OpenVPN server and try to start it, OpenVPN
throws a segfault  kernel: [3725586.167177] openvpn[28364]: segfault at 0 ip
00007fd6e5e38fb4 sp 00007fff434f18f0 error 4 in
openvpn-auth-pam.so[7fd6e5e38000+3000]   Ugggg I can't win for loosing.
Google turns up no joy on Segfaults with openvpn-auth-pam.so. So I'm back to
square one.

Anybody have any other suggestions I can try? I'm pretty much at my wits end
with this one, and stuck. Just not sure what to try next. Does anyone have a
working PPTPD via Radius config they would like to share? I might be missing
something, but I have been over things a couple two three times the past
couple of days. Here is my original post about my PPTPD issue.
http://ubuntuforums.org/showthread.php?t=1517219 again any help at this
point and time would be GREAT.

Thanks for your time,
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.ubuntu.com/archives/ubuntu-server/attachments/20100625/2bfe4aa9/attachment.html>

More information about the ubuntu-server mailing list