System Performance under heavy I/O load

Gerald Drouillard gerrylist at drouillard.ca
Wed Apr 28 21:08:54 UTC 2010


On 4/28/2010 3:25 PM, Preston Hagar wrote:
> On Wed, Apr 21, 2010 at 10:00 AM, Dr. Nils Jungclaus
> <Nils.Jungclaus at perfact.de>  wrote:
>    
>> Hi,
>>
>> I am using 8.04 on several (well equipped) servers and experience the
>> following problem on all of them:
>>
>> When doing larger I/O jobs like backup, I always get a very poor interactive
>> response of the system. Interactive in this case means performance of
>> database requests, web application requests and even interactive tools like
>> top. The usual setup looks like this:
>>
>> - postgres DB as database backend
>> - apache as loadbalancer and certificate handler
>> - several parallel zope instances using zeo
>> - sometimes more things like vmware-server, samba, postfix
>>
>> When I start a backup (via network using rsync, local to another HD using
>> rsync, or using a USB attached external drive), I get lots of delayed
>> processes in top (D), the iowait percentage goes up to 10 to 20 percent, but
>> the throughput (watched via iostat) is not very high, at least far away from
>> the rates I get using only one device. The load goes up to 20 or 30, and
>> nothing really gets done by the system. It seams to me that the system is
>> standing on it's own feet.
>>
>>      
Try:
nice -n16 ionice -c2 -n7 [your rsync command line here]

-- 
Regards
--------------------------------------
Gerald Drouillard
Technology Architect
Drouillard&  Associates, Inc.
http://www.Drouillard.biz





More information about the ubuntu-server mailing list