NFS Timeouts

Nick Webb nick at
Thu Jun 5 19:19:43 UTC 2008

Hi All -

On a Linux email server (postfix/courier-imap) I'm NFS mounting /home 
and seeing the occasional error like:

Jun  5 11:37:06 localhost kernel: [ 9924.401601] nfs: server not responding, timed out

At first I suspected network issues, so to isolate that I've put in a 
crossover cable between the two hosts and setup a dedicated private 
network just for NFS.  Problem still happens.  Next I read that perhaps 
higher rsize and wsize arguments could cause this, especially due to bad 
network equipment, so I went ahead and tried rsize/wsize=1024 instead of 
4096, no dice.

Finally I was mounting the shares as "sync,soft" which could be bad for 
email, so I changed that to "sync,hard,intr", but still no dice.  These 
errors don't seem major, but I'd like to get them fixed.  Users 
occasionally see a error on their mail clients when connecting to IMAP.

/etc/exports on the server:
/home         ,sync,no_root_squash),sync,root_squash)

/etc/fstab on the client: /home            nfs 
rw,sync,auto,hard,intr,rsize=1024,wsize=1024,timeo=14        0       0

Any suggestions?  It's been a while since I've done anything major over 
NFS, so I'm sure I'm a bit rusty.  If it helps the client server is 
Ubuntu Dapper Server (6.04) and the server is Ubuntu Hardy Server 
(8.04).  Neither server get's very loaded... no errors on the network 
devices via ifconfig, etc.


More information about the ubuntu-server mailing list