8.04-1 won't boot from degraded raid

Kees Cook kees at ubuntu.com
Tue Aug 26 17:09:19 UTC 2008


On Tue, Aug 26, 2008 at 12:44:36PM -0400, David Miller wrote:
> But I don't think that Michael is alone here.  I know that this particular
> issue has prevented us from deploying Ubuntu on our servers.  I would
> imagine that this issue is a show stopper for other potential customers who
> would be willing to pay for support contracts as well.

Certainly -- that's why it has finally reached the top of the server
team's priority list and is being solved.  Other stuff needed to be done
first, and no one else stepped up to see it through earlier than now.

Note that booting degraded has never worked in Ubuntu.  And the reasons
are mostly due to missing RAID boot support at every level[1].  It isn't
a "simple" fix -- I started spec'ing the solution during Hardy's
development cycle, and it has continued in Intrepid with Dustin getting
it working 100%.

> Now having said that I'm glad that this problem is finally getting some
> attention.  But for it to be a viable option here it has to be in a LTS
> release so what are the chances of this getting back ported to Hardy once
> it's released in Intrepid?  Considering that the LTS server users are the
> Ubuntu market segment that will benefit from this the most from this and are
> the ones who are willing to pay for support contracts.

The solution involves significant changes to initramfs, mdadm, lvm,
and grub.  Making changes like that in an update for LTS would require
a lot of time in testing, etc.  This kind of a decision isn't something
taken lightly, and the default answer has been to not backport new
features unless there is an overwhelming reason to do so.  It's up to
Rick Clark and Matt Zimmerman to overturn this decision.

If it's any consolation (as you can see from my linked blog post),
this has been a giant frustration for me as well -- I've got Hardy
machines on RAID that I had to manually make sure grub was set up on,
and won't boot without manual intervention.  It's a bug that has always
been present, and one that is fixed in Intrepid finally.


[1] http://www.outflux.net/blog/archives/2006/04/23/grub-yaird-mdadm-and-missing-drives/

Kees Cook
Ubuntu Security Team

More information about the ubuntu-server mailing list