New Server Tasks

Leonel Nunez leonel at enelserver.com
Thu Sep 20 12:21:48 UTC 2007


> Sorry if I restart a conversation that may have occured before I joined,
> but looking at Soren's news tasks at
> http://people.ubuntu.com/~soren/new-tasks/ a few questions came to my mind
> :
>
> Short term :
> a/ is there a good reason why spamd and clamd (or other similar tools)
> are not part of the mail server task at this point ?
> I can barely imagine someone running a mail server nowdays without some
> kind of anti spam/anti virus nowdays...
>

Agree and in:
http://wiki.ubuntu.com/MOTU/Clamav

we are trying backport the newest clamav to Dapper first, everytime clamav
has an upstream release the ubuntu version starts showing a message  that
the instalation it's outdated, and that message gives no confidence to new
users or even advanced users that know that a better virus detection was
released.

We'd like to have a task/package/repository  with the newest clamav for
ubuntu LTS.

This happens when you start clamav in dapper :

LibClamAV Warning: ********************************************************
LibClamAV Warning: ***  This version of the ClamAV engine is outdated.  ***
LibClamAV Warning: *** DON'T PANIC! Read http://www.clamav.net/faq.html ***
LibClamAV Warning: ********************************************************
LibClamAV Warning: Signature for Trojan.Small-3108 requires new ClamAV
version. Please update!
LibClamAV Warning: Signature for W32.Cervan requires new ClamAV version.
Please update!
LibClamAV Warning: Signature for Trojan.Small-3169 requires new ClamAV
version. Please update!
LibClamAV Warning: Signature for Trojan.Small-3171 requires new ClamAV
version. Please update!
LibClamAV Warning: Signature for W32.Dwee-1 requires new ClamAV version.
Please update!
LibClamAV Warning: Signature for Trojan.Small-3184 requires new ClamAV
version. Please update!
LibClamAV Warning: Signature for Trojan.Small-3204 requires new ClamAV
version. Please update!
LibClamAV Warning: Signature for Trojan.Crypted-4 requires new ClamAV
version. Please update!
LibClamAV Warning: Signature for Trojan.Packed-75 requires new ClamAV
version. Please update!
LibClamAV Warning: Signature for Trojan.Small-3358 requires new ClamAV
version. Please update!
LibClamAV Warning: Signature for Trojan.Packed-89 requires new ClamAV
version. Please update!
LibClamAV Warning: Signature for Trojan.Zlob-203 requires new ClamAV
version. Please update!
LibClamAV Warning: Signature for Trojan.Small-3658 requires new ClamAV
version. Please update!
LibClamAV Warning: Signature for Trojan.Small-3663 requires new ClamAV
version. Please update!
LibClamAV Warning: Signature for Trojan.Packed-93 requires new ClamAV
version. Please update!
LibClamAV Warning: Signature for Trojan.Downloader-13402 requires new
ClamAV version. Please update!
LibClamAV Warning: Signature for Trojan.Small-4082 requires new ClamAV
version. Please update!


---------
And the server administrator gets a mail with this message :

ClamAV update process started at Thu Sep 20 05:54:03 2007
WARNING: Your ClamAV installation is OUTDATED!
WARNING: Local version: 0.88.2 Recommended version: 0.91.2
DON'T PANIC! Read http://www.clamav.net/faq.html
main.cvd is up to date (version: 44, sigs: 133163, f-level: 20, builder:
sven)
WARNING: Your ClamAV installation is OUTDATED!
WARNING: Current functionality level = 8, recommended = 20
DON'T PANIC! Read http://www.clamav.net/faq.html
daily.cvd is up to date (version: 4350, sigs: 21532, f-level: 21, builder:
ccordes)
WARNING: Your ClamAV installation is OUTDATED!
WARNING: Current functionality level = 8, recommended = 21
DON'T PANIC! Read http://www.clamav.net/faq.html

everytime the  virus database is updated

even is a patched and working version  is getting useless with every new
clamav  release.

I think clamav is an important part for the ubuntu server.


> b/ what is the reasoning behind including mutt and no webmail ?  I know
> that 90% of our target users will never read their mail from the
> console... Roundcube has been mentionned yesterday on IRC but I have
> been running it for a little while and think it is a bit too young just
> yet.  Would rather recommend squirelmail.
>

Agree  and  squirrelmail works on most browsers even celular phones.


Leonel





More information about the ubuntu-server mailing list