A modest suggestion (or 2)

Liam Proven lproven at gmail.com
Mon Dec 11 21:00:20 UTC 2006

Just been building a new Ubuntu test box here, which involves removing
W2K Server from it and replacing a dead drive in its RAID.

However, I encountered 2 problems which are so common with Ubuntu
Server on legacy kit that they count as FAQs for me & some friends

[1] It has a NE2000 NIC. This is all it needs - my network here is
10Mb Cheapernet, because this means a lot fewer cables, it's not
merely cheap but free and it's still faster than my broadband uplink,
the main thing the network carries.

I don't expect modern distros to autodetect ISA cards. Some used to
but that was years ago. This machine also has an Adaptec 1542 ISA SCSI
AHA and an ISA sound card, both of which I've pulled for now.

The thing is this: I can manually add the NE2000 using "insmod ne
io=0x300 irq=9" and that works. I can't set it to DHCP but I can
manually run "dhclient".

It would be nice to do this easily through "modconf", but that is only
in the Universe repository, so I have to get online first to be able
to install my network card - which I need to get online. [Sighs again]

For users who don't know which modules to load, what the parameter
syntax is, what config files in /etc to modify to set its modes of
operation or whatever, "modconf" is a lifesaver. It gives
comprehensive lists of module names and so on and is easily driven
through text-mode menus.

But you can't use it to configure your network connection because it's
only in Universe so you must already be online to configure it.

Is this not a good candidate for inclusion in the CD ISO?

[2] I had major problems getting the server to boot because of issues
with GRUB. More details if these are requested. It would be nice if
LILO were still there as an alternative. I even tried putting GRUB in
the boot sector of the root partition and booting PowerQuest BootMagic
from DOS. That worked fine, but as soon as BootMagic hands over to
GRUB, the machine resets.

And that's because of a problem I've mentioned here before. GRUB is
not really what I'm asking about.

The thing is, my server has an AMD K6-3D 333MHz CPU. The Ubuntu Server
install CD runs fine on this, but once it's installed, it won't boot.

Because the sodding "linux-image-server" kernel is 686-only and won't
run on a K6-3D. I had to boot from the CD, which uses a generic 386
kernel, and apt-get install linux-image-386. Thankfully I was
half-expecting this -  I have encountered it before & so has a friend
of mine who's working with me on my Ubuntu Server project - but it's
bl**dy silly thing to do, to optimise the default kernel in such a way
as to make it unable to run on many perfectly suitable servers. My
mate's server is a Shuttle SFF box with a Via Samuel processor; Ubuntu
Server won't run on that, either. It's not only a problem for old
junkers like my test box.

I see no reason not to include a 686-optimised kernel, but making it
the default is a bad idea. Mainstream Ubuntu doesn't do it; why should
Ubuntu Server?

Liam Proven · Blog, homepage &c: http://lproven.livejournal.com/profile
Email: lproven at cix.co.uk · GMail/Google Talk/Orkut: lproven at gmail.com
Tel: +44 20-8685-0498 · Mob: +44 7939-087884 · Fax: + 44 870-9151419
AOL/AIM/iChat: liamproven at aol.com · MSN/Messenger: lproven at hotmail.com
Yahoo: liamproven at yahoo.co.uk · Skype: liamproven · ICQ: 73187508

More information about the ubuntu-server mailing list