[Bug 1748827] Re: package apache2 2.4.29-1ubuntu3 failed to install/upgrade: installed apache2 package post-installation script subprocess returned error exit status 1

Andreas Hasenack andreas at canonical.com
Wed Mar 28 12:57:35 UTC 2018


Thanks for filing this bug in Ubuntu.

Your Apache installation seems pretty broken:
ls: cannot access '/etc/apache2/mods-enabled/mpm_*.load': No such file or directory
error: mpm prefork not found in 'apache2_switch_mpm prefork' for package libapache2-mod-php7.1
info: Executing deferred 'a2enmod php7.1' for package libapache2-mod-php7.1
ERROR: Module php7.1 does not exist!
dpkg: error processing package apache2 (--configure):
 installed apache2 package post-installation script subprocess returned error exit status 1

Not only that, one can see in the data provided in the bug description
that a lot of config files in /etc/apache2/ are missing.

I suggest you reinstall the apache2 packages.

In the meantime, I'll mark this bug as invalid. The software cannot work
without critical components, and the configuration file structure in
/etc/apache2 needs to be there.

** Changed in: apache2 (Ubuntu)
       Status: New => Invalid

-- 
You received this bug notification because you are a member of Ubuntu
Server, which is subscribed to apache2 in Ubuntu.
https://bugs.launchpad.net/bugs/1748827

Title:
  package apache2 2.4.29-1ubuntu3 failed to install/upgrade: installed
  apache2 package post-installation script subprocess returned error
  exit status 1

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/apache2/+bug/1748827/+subscriptions



More information about the Ubuntu-server-bugs mailing list