[Bug 1676977] Re: Login prompt never presented with ldap login and ldapi set with a name.

Andreas Hasenack andreas at canonical.com
Fri Mar 2 14:36:43 UTC 2018


The ldapi:/// worked just fine, as did ldap:// with an IP or a name. And
I don't have an entry in /etc/hosts for the ldap server, I'm really
using DNS. Reboot works just fine, login prompt, and I can login at the
console (and via ssh) with an ldap user.

I'm sorry but I will need the files I requested in comment #16.

Here are mine:

ubuntu at 04-57:~$ cat /etc/ldap.conf | grep -vE "^(#|$)"
base dc=example,dc=com
uri ldap://xenial-slapd-server.lxd
ldap_version 3
pam_password exop


ubuntu at 04-57:~$ cat /etc/ldap/ldap.conf | grep -vE "^(#|$)"
URI    ldap://xenial-slapd.server.lxd
BASE dc=example,dc=com
TLS_CACERT	/etc/ssl/certs/ca-certificates.crt


I used these ldif files to minimally populate the ldap server:

ubuntu at 04-57:~$ cat base.ldif  usergroup.ldif 
dn: ou=People,dc=example,dc=com
ou: People
objectClass: organizationalUnit

dn: ou=Group,dc=example,dc=com
ou: Group
objectClass: organizationalUnit
dn: uid=testuser1,ou=People,dc=example,dc=com
uid: testuser1
objectClass: inetOrgPerson
objectClass: posixAccount
cn: testuser1
sn: testuser1
givenName: testuser1
mail: testuser1 at example.com
userPassword: testuser1secret
uidNumber: 10001
gidNumber: 10001
loginShell: /bin/bash
homeDirectory: /home/testuser1

dn: cn=testuser1,ou=Group,dc=example,dc=com
cn: testuser1
objectClass: posixGroup
gidNumber: 10001
memberUid: testuser1

dn: cn=ldapusers,ou=Group,dc=example,dc=com
cn: ldapusers
objectClass: posixGroup
gidNumber: 10100
memberUid: testuser1


** Attachment added: "ldaplogin.png"
   https://bugs.launchpad.net/ubuntu/+source/libpam-ldap/+bug/1676977/+attachment/5067121/+files/ldaplogin.png

-- 
You received this bug notification because you are a member of Ubuntu
Server Team, which is subscribed to libpam-ldap in Ubuntu.
https://bugs.launchpad.net/bugs/1676977

Title:
  Login prompt never presented with ldap login and ldapi set with a
  name.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/accountsservice/+bug/1676977/+subscriptions



More information about the Ubuntu-server-bugs mailing list