[Bug 1715827] Re: WINBIND failed to set up after migration from 16.10 to 17.04

Andreas Hasenack andreas at canonical.com
Fri Sep 8 13:02:16 UTC 2017


Thanks for filing this bug in Ubuntu.

You have an incorrect parameter in your [public] share, please fix that:

        direcory mask = 0777

testparm(1) is also complaining about your setting of the guest account
in a share:

"""
Global parameter guest account found in service section!
"""

testparm(1) isn't flagging the above as fatal errors, but they should be
fixed.

Since your role is an AD/DC server (server role = active directory
domain controller), you need to adjust the services that start on your
machine. It's not clear from the logs if you have done so or not. If you
haven't, please follow the instructions below:

"""
In an AD/DC server, you need to disable the individual samba services smbd, nmbd and winbind, and only start the new samba-ad-dc service, which will take care of starting and handling the lifecycle of the individual services

sudo systemctl stop smbd.service nmbd.service winbind.service
sudo systemctl disable smbd.service nmbd.service winbind.service
sudo systemctl unmask samba-ad-dc.service
sudo systemctl enable samba-ad-dc.service
sudo systemctl restart samba-ad-dc.service

After that's done, tell apt to try to finish the interrupted package
installation/upgrade that triggered this bug report:

sudo apt update
sudo apt -f install
"""

Please let us know how it goes.


** Changed in: samba (Ubuntu)
       Status: New => Incomplete

-- 
You received this bug notification because you are a member of Ubuntu
Server Team, which is subscribed to samba in Ubuntu.
https://bugs.launchpad.net/bugs/1715827

Title:
  WINBIND failed to set up after migration from 16.10 to 17.04

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/samba/+bug/1715827/+subscriptions



More information about the Ubuntu-server-bugs mailing list