[Bug 1700527] Re: removal of patch fix-1584485-trusty missed a d/rules change

Andreas Hasenack andreas at canonical.com
Mon Jun 26 13:10:06 UTC 2017


** Description changed:

  The removal of the patch fix-1584485 in artful's 2:4.5.8+dfsg-2ubuntu2 missed this debian/rules change:
  diff -Nru samba-4.3.11+dfsg/debian/rules samba-4.3.11+dfsg/debian/rules
  --- samba-4.3.11+dfsg/debian/rules	2016-05-24 07:47:31.000000000 -0400
  +++ samba-4.3.11+dfsg/debian/rules	2016-10-17 11:57:04.000000000 -0300
  @@ -65,6 +65,7 @@
-  		--disable-avahi \
-  		--disable-rpath \
-  		--disable-rpath-install \
+    --disable-avahi \
+    --disable-rpath \
+    --disable-rpath-install \
  +		--nonshared-binary=winbindd/winbindd \
-  		--bundled-libraries=NONE,pytevent,iniparser,roken,wind,hx509,asn1,heimbase,hcrypto,krb5,gssapi,heimntlm,hdb,kdc,com_err,compile_et,asn1_compile \
-  		--builtin-libraries=replace,ccan,samba-cluster-support \
-  		--minimum-library-version="$(shell ./debian/autodeps.py --minimum-library-version)"
+    --bundled-libraries=NONE,pytevent,iniparser,roken,wind,hx509,asn1,heimbase,hcrypto,krb5,gssapi,heimntlm,hdb,kdc,com_err,compile_et,asn1_compile \
+    --builtin-libraries=replace,ccan,samba-cluster-support \
+    --minimum-library-version="$(shell ./debian/autodeps.py --minimum-library-version)"
  
  This change should be removed as well.
+ 
+ Here is the original full diff of when fix-1584485 was introduced:
+ http://launchpadlibrarian.net/292793525/samba_2%3A4.4.5+dfsg-
+ 2ubuntu5_2%3A4.4.5+dfsg-2ubuntu5.1.diff.gz
+ 
+ The last hunk at the very bottom is what I forgot to drop in my 2:4.5.8
+ +dfsg-2ubuntu2 upload.

-- 
You received this bug notification because you are a member of Ubuntu
Server Team, which is subscribed to samba in Ubuntu.
https://bugs.launchpad.net/bugs/1700527

Title:
  removal of patch fix-1584485-trusty missed a d/rules change

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/samba/+bug/1700527/+subscriptions



More information about the Ubuntu-server-bugs mailing list