[Bug 1029889] Re: LVM Based KVM VM taking 100% CPU on first start and hangs.

Lewdmole admin at kvantanet.com
Wed Jul 24 10:29:17 UTC 2013

*** This bug is a duplicate of bug 1012946 ***

Still not fixed... I have found a workaround which was working (bellow) but now its not working anymore...
Same stuff like above in previous posts...

Someone spotted: 
Please note that if you want to create a qunatal or precise guest, you need to either add the option --addpkg=linux-image-generic or apply the patch from 
because otherwise the build process will fail!!!

This KVM installation with VMBuilder is rotten somewhere deep in my opinion, it has never worked properly.
This is a different machine (X86_64) a lots of memory and space...

1.) Instal VM as file based with --addpkg=linux-image-generic
2.) Wait for the install to finish...
Afterwards, you can find an XML configuration file for the VM in /etc/libvirt/qemu/ 
(=> /etc/libvirt/qemu/vm4.xml):

root at host:~# ls -l /etc/libvirt/qemu/

This process will create VM image (qcow2) in /var/lib/libvirt/images/vm4

root at host:~# cd /var/lib/libvirt/images/vm4/ubuntu-kvm

Now that we know the name of our image (tmp09XnBf.qcow2), we can convert
it as follows:

root at host:~# qemu-img convert tmp09XnBf.qcow2 -O raw /dev/virtualvg2/vm4

Afterwards you can delete the disk image:

root at host:~# rm -f tmp09XnBf.qcow2

Now we must modify the VM's configuration...

root at host:~# virsh edit vm4

... and change the following section...

    <disk type='file' device='disk'>
      <driver name='qemu' type='qcow2'/>
      <source file='/var/lib/libvirt/images/vm4/ubuntu-kvm/tmp09XnBf.qcow2'/>
      <target dev='hda' bus='ide'/>
      <address type='drive' controller='0' bus='0' unit='0'/>

... so that it looks as follows:

    <disk type='file' device='disk'>
      <driver name='qemu' type='raw'/>
      <source file='/dev/virtualvg2/vm4'/>
      <target dev='hda' bus='ide'/>
      <address type='drive' controller='0' bus='0' unit='0'/>

Now we activate the VM:

root at host:~# virsh --connect qemu:///system
virsh # define /etc/libvirt/qemu/vm4.xml
virsh # start vm4
Making VM survive host reboot
virsh # autostart vm4

Result now not working taking 100% cpu and hangs!

You received this bug notification because you are a member of Ubuntu
Server Team, which is subscribed to qemu-kvm in Ubuntu.

  LVM Based KVM VM taking 100% CPU on first start and hangs.

To manage notifications about this bug go to:

More information about the Ubuntu-server-bugs mailing list