[Bug 941968] Re: lockfile-create hangs inside lxc containers (potential buffer overflow?)

Sebastian Hoffmann null.s.hoffmann at googlemail.com
Fri Jan 4 04:58:02 UTC 2013

Sure. First, I ssh'd to project64198 at deneb, a (metal) server of mine.
There prepared for local deployment:

sudo apt-get install python-software-properties
sudo add-apt-repository ppa:juju/pkgs
sudo apt-get update && sudo apt-get install juju
sudo apt-get install lxc apt-cacher-ng libzookeeper-java zookeeper

Now I ran juju bootstrap and got a .juju/environments.yaml, which I

    type: local
    control-bucket: juju-c81e728d9d4c2f636f067f89cc14862c
    admin-secret: eccbc87e4b5ce2fe28308fd9f2a7baf3
    default-series: precise
    juju-origin: ppa
    data-dir: /home/project64198/democluster

Also, I ran ssh-keygen -t rsa and mkdir democluster, and prepared for
hbase by writing this config.yaml:

    hbase: True
    hbase: True
    monitoring_port: 9090

After another juju bootstrap I deployed my cloud:

juju deploy zookeeper
juju deploy --config config.yaml hadoop hadoop-master
juju deploy --config config.yaml hadoop hadoop-workers
juju deploy hbase hbase-master
juju deploy hbase hbase-regions
juju add-relation hadoop-master:namenode hadoop-workers:datanode
juju add-relation hbase-master zookeeper
juju add-relation hbase-regions zookeeper
juju add-relation hadoop-master:namenode hbase-master:namenode
juju add-relation hadoop-master:namenode hbase-regions:namenode
juju add-relation hbase-master:master hbase-regions:regionserver

It was at this point that hbase-master would stick in agent-state: pending, public-address: null
So I ran juju destroy-environment, changed these lines in .juju/environments.yaml:

    data-dir: /home/project64198/demo

After an mkdir demo, juju bootstrap and all the deploys and add-
relations, my cloud was up.

You received this bug notification because you are a member of Ubuntu
Server Team, which is subscribed to ntp in Ubuntu.

  lockfile-create hangs inside lxc containers (potential buffer

To manage notifications about this bug go to:

More information about the Ubuntu-server-bugs mailing list