[Bug 954368] Re: Upstart script puppet agent

Glenn Aaldering glenn at openvideo.nl
Wed Mar 21 10:31:07 UTC 2012

Hi James,

Thanks for your feedback!

1) The upstart script has been extended with daemon checks, checks on the defaults file flags and also give error outputs. I added the puppet.conf upstart script as attachment.
2) Since mongrel support will be deleted from debian (http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=663921) im assuming that ubuntu 12.10 wont have mongrel support either. This would mean that the puppetmaster upstart script wont need to support the mongrel backend and only standard webrick. See attachment puppetmaster.conf
3) Also added the puppetqd upstart script as attachment in puppetqd.conf.
4) It would be nice to have an upstart script for puppetmaster-passenger too. But i think this would be the apache2 upstart script. Is there any eta on the apache2 upstart script, or if someone is working on that already?

** Bug watch added: Debian Bug tracker #663921

** Attachment added: "puppet.conf"

You received this bug notification because you are a member of Ubuntu
Server Team, which is subscribed to puppet in Ubuntu.

  Upstart script puppet agent

To manage notifications about this bug go to:

More information about the Ubuntu-server-bugs mailing list