[Bug 795800] Re: virsh save fails on oneiric when the apparmor security driver is enabled

Launchpad Bug Tracker 795800 at bugs.launchpad.net
Thu Jun 16 20:00:22 UTC 2011


This bug was fixed in the package libvirt - 0.9.1-1ubuntu4

---------------
libvirt (0.9.1-1ubuntu4) oneiric; urgency=low

  * SECURITY UPDATE: 0.8.8 regression which reopens disk probing
    (CVE-2010-2238). This can be dropped in 0.9.2.
    - 9025-CVE-2011-2178.patch: use correct pointer address in
      virSecurityManagerGetPrivateData()
    - CVE-2011-2178
  * fix virsh save when AppArmor driver is enabled
    - 9026-lp795800.patch: src/security/security_apparmor.c: implement
      AppArmorSetFDLabel(), which is now used by qemuMigrationToFile() if
      our version of qemu supports fd migraton. This can be dropped in 0.9.3.
    - LP: #795800
 -- Jamie Strandboge <jamie at ubuntu.com>   Thu, 16 Jun 2011 14:16:00 -0500

** Changed in: libvirt (Ubuntu Oneiric)
       Status: In Progress => Fix Released

** CVE added: http://www.cve.mitre.org/cgi-
bin/cvename.cgi?name=2010-2238

** CVE added: http://www.cve.mitre.org/cgi-
bin/cvename.cgi?name=2011-2178

-- 
You received this bug notification because you are a member of Ubuntu
Server Team, which is subscribed to libvirt in Ubuntu.
https://bugs.launchpad.net/bugs/795800

Title:
  virsh save fails on oneiric when the apparmor security driver is
  enabled

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/libvirt/+bug/795800/+subscriptions



More information about the Ubuntu-server-bugs mailing list